CVE-2026-75858
CVE-2026-75858 · CodeWhale rlm_eval before 0.8.64 Remote Code Execution
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
CodeWhale (packages codewhale / codewhale-tui) versions >= 0.8.41 and < 0.8.64 contain a remote code execution vulnerability in the rlm_eval tool. The tool's approval_requirement() returns ApprovalRequirement::Auto, which the engine treats as 'never prompt,' causing arbitrary model-supplied Python code to run in a python3 interpreter without consulting the user's configured --approval-policy and without any approval prompt or audit step. An attacker can induce the agent to execute arbitrary code via prompt injection in untrusted content the agent reads (a web page, fetched URL, repository file, or MCP tool result); the companion rlm_open tool can stage such content. Code runs on the user's machine at the user's privilege level. Fixed in 0.8.64.
CVSS 8.5 · Alta · EPSS 0,4% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: node
Productos y versiones afectados
codewhale
- Versiones
- ≥ 0.8.33, < 0.8.41: Afectada (semver)
- 0.8.41: No afectada (semver)
Actualiza a 0.8.41
codewhale
- Versiones
- ≥ 0.8.41, < 0.8.64: Afectada (semver)
- 0.8.64: No afectada (semver)
Actualiza a 0.8.64
deepseek-tui crates.io
- Intervalos de versiones afectados
- SEMVER: ≥ 0.8.33, ≤ 0.8.41
Sin corrección publicada
deepseek-tui npm
- Intervalos de versiones afectados
- SEMVER: ≥ 0.8.33, < 0.8.41
Actualiza a 0.8.41
codewhale-tui crates.io
- Intervalos de versiones afectados
- SEMVER: ≥ 0.8.41, < 0.8.64
Actualiza a 0.8.64
codewhale npm
- Intervalos de versiones afectados
- SEMVER: ≥ 0.8.41, < 0.8.64
Actualiza a 0.8.64