p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de terriajs-server

Vulnerabilidades publicadas para terriajs-server en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 2

  1. CVE-2026-27818

    Alta · CVSS 8.7EPSS 0,28%Corrección disponible

    TerriaJS-Server has a domain validation bypass vulnerability in its proxy allowlist

    TerriaJS-Server is a NodeJS Express server for TerriaJS, a library for building web-based geospatial data explorers. A validation bug in versions prior to 4.0.3 allows an attacker to proxy domains not explicitly allowed in the `proxyableDomains` configuration. Version 4.0.3 fixes the issue.

    • Actualiza a 4.0.3
    Publicación Actualización
  2. GHSA-p72p-rjr2-r439

    Sin evaluarCorrección disponible

    Server-Side Request Forgery in terriajs-server

    Versions of `terriajs-server`prior to 2.7.4 are vulnerable to Server-Side Request Forgery (SSRF). If an attacker has access to a server whitelisted by the terriajs-server proxy or if the attacker is able to modify the DNS records of a domain whitelisted by the terriajs-server proxy, the attacker can use the terriajs-server proxy to access any HTTP-accessible resources that are accessible to the server, including private resources in the hosting environment. ## Recommendation Upgrade to version 2.7.4 or later.

    • Actualiza a 2.7.4
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →