p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in terriajs-server

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für terriajs-server: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 2

  1. CVE-2026-27818

    Hoch · CVSS 8.7EPSS 0,28%Korrektur verfügbar

    TerriaJS-Server has a domain validation bypass vulnerability in its proxy allowlist

    TerriaJS-Server is a NodeJS Express server for TerriaJS, a library for building web-based geospatial data explorers. A validation bug in versions prior to 4.0.3 allows an attacker to proxy domains not explicitly allowed in the `proxyableDomains` configuration. Version 4.0.3 fixes the issue.

    • Auf 4.0.3 aktualisieren
    Veröffentlicht Aktualisiert
  2. GHSA-p72p-rjr2-r439

    Nicht bewertetKorrektur verfügbar

    Server-Side Request Forgery in terriajs-server

    Versions of `terriajs-server`prior to 2.7.4 are vulnerable to Server-Side Request Forgery (SSRF). If an attacker has access to a server whitelisted by the terriajs-server proxy or if the attacker is able to modify the DNS records of a domain whitelisted by the terriajs-server proxy, the attacker can use the terriajs-server proxy to access any HTTP-accessible resources that are accessible to the server, including private resources in the hosting environment. ## Recommendation Upgrade to version 2.7.4 or later.

    • Auf 2.7.4 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →