p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de terriajs-server

Vulnérabilité publiée pour terriajs-server au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 2

  1. CVE-2026-27818

    Élevée · CVSS 8.7EPSS 0,28%Correctif disponible

    TerriaJS-Server has a domain validation bypass vulnerability in its proxy allowlist

    TerriaJS-Server is a NodeJS Express server for TerriaJS, a library for building web-based geospatial data explorers. A validation bug in versions prior to 4.0.3 allows an attacker to proxy domains not explicitly allowed in the `proxyableDomains` configuration. Version 4.0.3 fixes the issue.

    • Mettez à jour vers 4.0.3
    Publication Mise à jour
  2. GHSA-p72p-rjr2-r439

    Non évaluéeCorrectif disponible

    Server-Side Request Forgery in terriajs-server

    Versions of `terriajs-server`prior to 2.7.4 are vulnerable to Server-Side Request Forgery (SSRF). If an attacker has access to a server whitelisted by the terriajs-server proxy or if the attacker is able to modify the DNS records of a domain whitelisted by the terriajs-server proxy, the attacker can use the terriajs-server proxy to access any HTTP-accessible resources that are accessible to the server, including private resources in the hosting environment. ## Recommendation Upgrade to version 2.7.4 or later.

    • Mettez à jour vers 2.7.4
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →