p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de mediawiki/core

Vulnerabilidades publicadas para mediawiki/core en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 28

  1. CVE-2023-45363

    Alta · CVSS 7.5EPSS 23,78%Corrección disponible

    CVE-2023-45363

    An issue was discovered in ApiPageSet.php in MediaWiki before 1.35.12, 1.36.x through 1.39.x before 1.39.5, and 1.40.x before 1.40.1. It allows attackers to cause a denial of service (unbounded loop and RequestTimeoutException) when querying pages redirected to other variants with redirects and converttitles set.

    • Actualiza a 1.35.12
    • Actualiza a 1.39.5
    • Actualiza a 1.40.1
    Publicación Actualización
  2. CVE-2021-41800

    Media · CVSS 5.3EPSS 1,86%Corrección disponible

    CVE-2021-41800

    MediaWiki before 1.36.2 allows a denial of service (resource consumption because of lengthy query processing time). Visiting Special:Contributions can sometimes result in a long running SQL query because PoolCounter protection is mishandled.

    • Actualiza a 1.36.2
    Publicación Actualización
  3. CVE-2020-25827

    Alta · CVSS 7.5EPSS 1,7%Corrección disponible

    CVE-2020-25827

    An issue was discovered in the OATHAuth extension in MediaWiki before 1.31.10 and 1.32.x through 1.34.x before 1.34.4. For Wikis using OATHAuth on a farm/cluster (such as via CentralAuth), rate limiting of OATH tokens is only done on a single site level. Thus, multiple requests can be made across many wikis/sites concurrently.

    • Actualiza a 1.31.9
    • Actualiza a 1.34.3
    Publicación Actualización
  4. CVE-2020-25828

    Media · CVSS 6.1EPSS 1,09%Corrección disponible

    CVE-2020-25828

    An issue was discovered in MediaWiki before 1.31.10 and 1.32.x through 1.34.x before 1.34.4. The non-jqueryMsg version of mw.message().parse() doesn't escape HTML. This affects both message contents (which are generally safe) and the parameters (which can be based on user input). (When jqueryMsg is loaded, it correctly accepts only whitelisted tags in message contents, and escapes all parameters. Situations with an unloaded jqueryMsg are rare in practice, but can for example occur for Special:SpecialPages on a wiki with no extensions installed.)

    • Actualiza a 1.31.9
    • Actualiza a 1.34.3
    • Actualiza a 1.35.0
    Publicación Actualización
  5. CVE-2020-25814

    Media · CVSS 6.1EPSS 1,35%Corrección disponible

    CVE-2020-25814

    In MediaWiki before 1.31.10 and 1.32.x through 1.34.x before 1.34.4, XSS related to jQuery can occur. The attacker creates a message with [javascript:payload xss] and turns it into a jQuery object with mw.message().parse(). The expected result is that the jQuery object does not contain an <a> tag (or it does not have a href attribute, or it's empty, etc.). The actual result is that the object contains an <a href ="javascript... that executes when clicked.

    • Actualiza a 1.31.9
    • Actualiza a 1.34.3
    • Actualiza a 1.35.0
    Publicación Actualización
  6. CVE-2020-25815

    Media · CVSS 6.1EPSS 1,1%Corrección disponible

    CVE-2020-25815

    An issue was discovered in MediaWiki 1.32.x through 1.34.x before 1.34.4. LogEventList::getFiltersDesc is insecurely using message text to build options names for an HTML multi-select field. The relevant code should use escaped() instead of text().

    • Actualiza a 1.34.3
    • Actualiza a 1.35.0
    Publicación Actualización
  7. CVE-2020-25812

    Media · CVSS 6.1EPSS 1,1%Corrección disponible

    CVE-2020-25812

    An issue was discovered in MediaWiki 1.34.x before 1.34.4. On Special:Contributions, the NS filter uses unescaped messages as keys in the option key for an HTMLForm specifier. This is vulnerable to a mild XSS if one of those messages is changed to include raw HTML.

    • Actualiza a 1.34.3
    • Actualiza a 1.35.0
    Publicación Actualización
  8. CVE-2020-15005

    Baja · CVSS 3.1EPSS 1,3%Corrección disponible

    CVE-2020-15005

    In MediaWiki before 1.31.8, 1.32.x and 1.33.x before 1.33.4, and 1.34.x before 1.34.2, private wikis behind a caching server using the img_auth.php image authorization security feature may have had their files cached publicly, so any unauthorized user could view them. This occurs because Cache-Control and Vary headers were mishandled.

    • Actualiza a 1.31.8
    • Actualiza a 1.33.4
    • Actualiza a 1.34.2
    Publicación Actualización
  9. CVE-2020-10960

    Media · CVSS 5.3EPSS 1,15%Corrección disponible

    CVE-2020-10960

    In MediaWiki before 1.34.1, users can add various Cascading Style Sheets (CSS) classes (which can affect what content is shown or hidden in the user interface) to arbitrary DOM nodes via HTML content within a MediaWiki page. This occurs because jquery.makeCollapsible allows applying an event handler to any Cascading Style Sheets (CSS) selector. There is no known way to exploit this for cross-site scripting (XSS).

    • Actualiza a 1.31.7
    • Actualiza a 1.33.3
    • Actualiza a 1.34.1
    Publicación Actualización
  10. CVE-2019-19709

    Media · CVSS 6.1EPSS 1,56%Corrección disponible

    CVE-2019-19709

    MediaWiki through 1.33.1 allows attackers to bypass the Title_blacklist protection mechanism by starting with an arbitrary title, establishing a non-resolvable redirect for the associated page, and using redirect=1 in the action API when editing that page.

    • Actualiza a 1.31.6
    • Actualiza a 1.32.6
    • Actualiza a 1.33.2
    • Actualiza a 1.34.0
    Publicación Actualización
  11. CVE-2019-12474

    Alta · CVSS 7.5EPSS 2,04%Corrección disponible

    CVE-2019-12474

    Wikimedia MediaWiki 1.23.0 through 1.32.1 has an information leak. Privileged API responses that include whether a recent change has been patrolled may be cached publicly. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.

    • Actualiza a 1.27.6
    • Actualiza a 1.30.2
    • Actualiza a 1.31.2
    • Actualiza a 1.32.2
    Publicación Actualización
  12. CVE-2019-12472

    Alta · CVSS 7.5EPSS 1,32%Corrección disponible

    CVE-2019-12472

    An Incorrect Access Control vulnerability was found in Wikimedia MediaWiki 1.18.0 through 1.32.1. It is possible to bypass the limits on IP range blocks ($wgBlockCIDRLimit) by using the API. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.

    • Actualiza a 1.27.6
    • Actualiza a 1.30.2
    • Actualiza a 1.31.2
    • Actualiza a 1.32.2
    Publicación Actualización
  13. CVE-2019-12471

    Media · CVSS 6.1EPSS 1,29%Corrección disponible

    CVE-2019-12471

    Wikimedia MediaWiki 1.30.0 through 1.32.1 has XSS. Loading user JavaScript from a non-existent account allows anyone to create the account, and perform XSS on users loading that script. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.

    • Actualiza a 1.27.6
    • Actualiza a 1.30.2
    • Actualiza a 1.31.2
    Publicación Actualización
  14. CVE-2019-12473

    Alta · CVSS 7.5EPSS 2,31%Corrección disponible

    CVE-2019-12473

    Wikimedia MediaWiki 1.27.0 through 1.32.1 might allow DoS. Passing invalid titles to the API could cause a DoS by querying the entire watchlist table. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.

    • Actualiza a 1.27.6
    • Actualiza a 1.30.2
    • Actualiza a 1.31.2
    • Actualiza a 1.32.2
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →