p PatchFirst

PatchFirst · Latest vulnerabilities

mediawiki/core vulnerabilities

Vulnerabilities published for mediawiki/core in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 28

  1. CVE-2023-45363

    High · CVSS 7.5EPSS 23.78%Fix available

    CVE-2023-45363

    An issue was discovered in ApiPageSet.php in MediaWiki before 1.35.12, 1.36.x through 1.39.x before 1.39.5, and 1.40.x before 1.40.1. It allows attackers to cause a denial of service (unbounded loop and RequestTimeoutException) when querying pages redirected to other variants with redirects and converttitles set.

    • Update to 1.35.12
    • Update to 1.39.5
    • Update to 1.40.1
    Published Updated
  2. CVE-2020-25827

    High · CVSS 7.5EPSS 1.7%Fix available

    CVE-2020-25827

    An issue was discovered in the OATHAuth extension in MediaWiki before 1.31.10 and 1.32.x through 1.34.x before 1.34.4. For Wikis using OATHAuth on a farm/cluster (such as via CentralAuth), rate limiting of OATH tokens is only done on a single site level. Thus, multiple requests can be made across many wikis/sites concurrently.

    • Update to 1.31.9
    • Update to 1.34.3
    Published Updated
  3. CVE-2020-25828

    Medium · CVSS 6.1EPSS 1.09%Fix available

    CVE-2020-25828

    An issue was discovered in MediaWiki before 1.31.10 and 1.32.x through 1.34.x before 1.34.4. The non-jqueryMsg version of mw.message().parse() doesn't escape HTML. This affects both message contents (which are generally safe) and the parameters (which can be based on user input). (When jqueryMsg is loaded, it correctly accepts only whitelisted tags in message contents, and escapes all parameters. Situations with an unloaded jqueryMsg are rare in practice, but can for example occur for Special:SpecialPages on a wiki with no extensions installed.)

    • Update to 1.31.9
    • Update to 1.34.3
    • Update to 1.35.0
    Published Updated
  4. CVE-2020-25814

    Medium · CVSS 6.1EPSS 1.35%Fix available

    CVE-2020-25814

    In MediaWiki before 1.31.10 and 1.32.x through 1.34.x before 1.34.4, XSS related to jQuery can occur. The attacker creates a message with [javascript:payload xss] and turns it into a jQuery object with mw.message().parse(). The expected result is that the jQuery object does not contain an <a> tag (or it does not have a href attribute, or it's empty, etc.). The actual result is that the object contains an <a href ="javascript... that executes when clicked.

    • Update to 1.31.9
    • Update to 1.34.3
    • Update to 1.35.0
    Published Updated
  5. CVE-2020-25812

    Medium · CVSS 6.1EPSS 1.1%Fix available

    CVE-2020-25812

    An issue was discovered in MediaWiki 1.34.x before 1.34.4. On Special:Contributions, the NS filter uses unescaped messages as keys in the option key for an HTMLForm specifier. This is vulnerable to a mild XSS if one of those messages is changed to include raw HTML.

    • Update to 1.34.3
    • Update to 1.35.0
    Published Updated
  6. CVE-2020-15005

    Low · CVSS 3.1EPSS 1.3%Fix available

    CVE-2020-15005

    In MediaWiki before 1.31.8, 1.32.x and 1.33.x before 1.33.4, and 1.34.x before 1.34.2, private wikis behind a caching server using the img_auth.php image authorization security feature may have had their files cached publicly, so any unauthorized user could view them. This occurs because Cache-Control and Vary headers were mishandled.

    • Update to 1.31.8
    • Update to 1.33.4
    • Update to 1.34.2
    Published Updated
  7. CVE-2020-10960

    Medium · CVSS 5.3EPSS 1.15%Fix available

    CVE-2020-10960

    In MediaWiki before 1.34.1, users can add various Cascading Style Sheets (CSS) classes (which can affect what content is shown or hidden in the user interface) to arbitrary DOM nodes via HTML content within a MediaWiki page. This occurs because jquery.makeCollapsible allows applying an event handler to any Cascading Style Sheets (CSS) selector. There is no known way to exploit this for cross-site scripting (XSS).

    • Update to 1.31.7
    • Update to 1.33.3
    • Update to 1.34.1
    Published Updated
  8. CVE-2019-19709

    Medium · CVSS 6.1EPSS 1.56%Fix available

    CVE-2019-19709

    MediaWiki through 1.33.1 allows attackers to bypass the Title_blacklist protection mechanism by starting with an arbitrary title, establishing a non-resolvable redirect for the associated page, and using redirect=1 in the action API when editing that page.

    • Update to 1.31.6
    • Update to 1.32.6
    • Update to 1.33.2
    • Update to 1.34.0
    Published Updated
  9. CVE-2019-12474

    High · CVSS 7.5EPSS 2.04%Fix available

    CVE-2019-12474

    Wikimedia MediaWiki 1.23.0 through 1.32.1 has an information leak. Privileged API responses that include whether a recent change has been patrolled may be cached publicly. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.

    • Update to 1.27.6
    • Update to 1.30.2
    • Update to 1.31.2
    • Update to 1.32.2
    Published Updated
  10. CVE-2019-12472

    High · CVSS 7.5EPSS 1.32%Fix available

    CVE-2019-12472

    An Incorrect Access Control vulnerability was found in Wikimedia MediaWiki 1.18.0 through 1.32.1. It is possible to bypass the limits on IP range blocks ($wgBlockCIDRLimit) by using the API. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.

    • Update to 1.27.6
    • Update to 1.30.2
    • Update to 1.31.2
    • Update to 1.32.2
    Published Updated
  11. CVE-2019-12471

    Medium · CVSS 6.1EPSS 1.29%Fix available

    CVE-2019-12471

    Wikimedia MediaWiki 1.30.0 through 1.32.1 has XSS. Loading user JavaScript from a non-existent account allows anyone to create the account, and perform XSS on users loading that script. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.

    • Update to 1.27.6
    • Update to 1.30.2
    • Update to 1.31.2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →