p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de ssddanbrown/bookstack

Vulnerabilidades publicadas para ssddanbrown/bookstack en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 10

  1. CVE-2020-26211

    Alta · CVSS 7.7EPSS 1,1%Corrección disponible

    Cross-Site Scripting in BookStack

    In BookStack before version 0.30.4, a user with permissions to edit a page could insert JavaScript code through the use of `javascript:` URIs within a link or form which would run, within the context of the current page, when clicked or submitted. Additionally, a user with permissions to edit a page could insert a particular meta tag which could be used to silently redirect users to a alternative location upon visit of a page. Dangerous content may remain in the database but will be removed before being displayed on a page. If you think this could have been exploited the linked advisory provides a SQL query to test. As a workaround without up

    • Actualiza a 0.30.4
    Publicación Actualización
  2. CVE-2020-11055

    Media · CVSS 6.3EPSS 0,78%Corrección disponible

    Cross-site Scripting in BookStack

    In BookStack greater than or equal to 0.18.0 and less than 0.29.2, there is an XSS vulnerability in comment creation. A user with permission to create comments could POST HTML directly to the system to be saved in a comment, which would then be executed/displayed to others users viewing the comment. Through this vulnerability custom JavaScript code could be injected and therefore ran on other user machines. This most impacts scenarios where not-trusted users are given permission to create comments. This has been fixed in 0.29.2.

    • Actualiza a 0.29.2
    Publicación Actualización
  3. CVE-2020-5256

    Alta · CVSS 7.9EPSS 1,97%Corrección disponible

    Remote Code Execution Through Image Uploads in BookStack

    BookStack before version 0.25.5 has a vulnerability where a user could upload PHP files through image upload functions, which would allow them to execute code on the host system remotely. They would then have the permissions of the PHP process. This most impacts scenarios where non-trusted users are given permission to upload images in any area of the application. The issue was addressed in a series of patches in versions 0.25.3, 0.25.4 and 0.25.5. Users should upgrade to at least v0.25.5 to avoid this vulnerability.

    • Actualiza a 0.25.5
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →