p PatchFirst

PatchFirst · Latest vulnerabilities

ssddanbrown/bookstack vulnerabilities

Vulnerabilities published for ssddanbrown/bookstack in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 10

  1. CVE-2020-26211

    High · CVSS 7.7EPSS 1.1%Fix available

    Cross-Site Scripting in BookStack

    In BookStack before version 0.30.4, a user with permissions to edit a page could insert JavaScript code through the use of `javascript:` URIs within a link or form which would run, within the context of the current page, when clicked or submitted. Additionally, a user with permissions to edit a page could insert a particular meta tag which could be used to silently redirect users to a alternative location upon visit of a page. Dangerous content may remain in the database but will be removed before being displayed on a page. If you think this could have been exploited the linked advisory provides a SQL query to test. As a workaround without up

    • Update to 0.30.4
    Published Updated
  2. CVE-2020-11055

    Medium · CVSS 6.3EPSS 0.78%Fix available

    Cross-site Scripting in BookStack

    In BookStack greater than or equal to 0.18.0 and less than 0.29.2, there is an XSS vulnerability in comment creation. A user with permission to create comments could POST HTML directly to the system to be saved in a comment, which would then be executed/displayed to others users viewing the comment. Through this vulnerability custom JavaScript code could be injected and therefore ran on other user machines. This most impacts scenarios where not-trusted users are given permission to create comments. This has been fixed in 0.29.2.

    • Update to 0.29.2
    Published Updated
  3. CVE-2020-5256

    High · CVSS 7.9EPSS 1.97%Fix available

    Remote Code Execution Through Image Uploads in BookStack

    BookStack before version 0.25.5 has a vulnerability where a user could upload PHP files through image upload functions, which would allow them to execute code on the host system remotely. They would then have the permissions of the PHP process. This most impacts scenarios where non-trusted users are given permission to upload images in any area of the application. The issue was addressed in a series of patches in versions 0.25.3, 0.25.4 and 0.25.5. Users should upgrade to at least v0.25.5 to avoid this vulnerability.

    • Update to 0.25.5
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →