p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de symfony/yaml

Vulnerabilidades publicadas para symfony/yaml en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 5

  1. CVE-2026-45305

    Alta · CVSS 8.7EPSS 0,68%Corrección disponible

    Symfony: YAML Parser ReDoS via Catastrophic Backtracking in Parser::cleanup() Regex

    Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, Symfony\Component\Yaml\Parser::cleanup() used regular expressions with overlapping quantifiers for YAML directive, comment, and document marker cleanup, allowing crafted input to make parsing hang for an arbitrarily long time. This issue is fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.

    • Actualiza a 5.4.52
    • Actualiza a 6.4.40
    • Actualiza a 7.4.12
    • Actualiza a 8.0.12
    Publicación Actualización
  2. CVE-2026-45304

    Alta · CVSS 8.7EPSS 0,68%Corrección disponible

    Symfony: YAML Parser Exponential Memory Allocation via Recursive Collection-Alias Expansion ("Billion Laughs")

    Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, Symfony\Component\Yaml\Parser resolved YAML collection aliases recursively, allowing a small untrusted YAML input to expand into a multi-gigabyte structure and exhaust memory. This issue is fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.

    • Actualiza a 5.4.52
    • Actualiza a 6.4.40
    • Actualiza a 7.4.12
    • Actualiza a 8.0.12
    Publicación Actualización
  3. CVE-2026-45133

    Alta · CVSS 8.2EPSS 0,63%Corrección disponible

    Symfony: [Yaml] Harden the parser when handling untrusted input

    Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, when the parser is exposed to attacker-controlled input, deeply nested mappings or sequences cause both the block-level (Parser::parseBlock()) and inline (Inline::parseSequence() / Inline::parseMapping()) parsers to recurse without a depth limit. A crafted document exhausts the PHP stack and crashes the worker. This issue is fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.

    • Actualiza a 5.4.52
    • Actualiza a 6.4.40
    • Actualiza a 7.4.12
    • Actualiza a 8.0.12
    Publicación Actualización
  4. CVE-2013-1397

    Sin evaluarEPSS 1,62%Corrección disponible

    CVE-2013-1397

    Symfony 2.0.x before 2.0.22, 2.1.x before 2.1.7, and 2.2.x remote attackers to execute arbitrary PHP code via a serialized PHP object to the (1) Yaml::parse or (2) Yaml\Parser::parse function, a different vulnerability than CVE-2013-1348.

    • Actualiza a 2.0.22
    • Actualiza a 2.1.7
    • Actualiza a 2.2.0-BETA2
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →