p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in symfony/yaml

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für symfony/yaml: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 5

  1. CVE-2026-45305

    Hoch · CVSS 8.7EPSS 0,68%Korrektur verfügbar

    Symfony: YAML Parser ReDoS via Catastrophic Backtracking in Parser::cleanup() Regex

    Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, Symfony\Component\Yaml\Parser::cleanup() used regular expressions with overlapping quantifiers for YAML directive, comment, and document marker cleanup, allowing crafted input to make parsing hang for an arbitrarily long time. This issue is fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.

    • Auf 5.4.52 aktualisieren
    • Auf 6.4.40 aktualisieren
    • Auf 7.4.12 aktualisieren
    • Auf 8.0.12 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2026-45304

    Hoch · CVSS 8.7EPSS 0,68%Korrektur verfügbar

    Symfony: YAML Parser Exponential Memory Allocation via Recursive Collection-Alias Expansion ("Billion Laughs")

    Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, Symfony\Component\Yaml\Parser resolved YAML collection aliases recursively, allowing a small untrusted YAML input to expand into a multi-gigabyte structure and exhaust memory. This issue is fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.

    • Auf 5.4.52 aktualisieren
    • Auf 6.4.40 aktualisieren
    • Auf 7.4.12 aktualisieren
    • Auf 8.0.12 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2026-45133

    Hoch · CVSS 8.2EPSS 0,63%Korrektur verfügbar

    Symfony: [Yaml] Harden the parser when handling untrusted input

    Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, when the parser is exposed to attacker-controlled input, deeply nested mappings or sequences cause both the block-level (Parser::parseBlock()) and inline (Inline::parseSequence() / Inline::parseMapping()) parsers to recurse without a depth limit. A crafted document exhausts the PHP stack and crashes the worker. This issue is fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.

    • Auf 5.4.52 aktualisieren
    • Auf 6.4.40 aktualisieren
    • Auf 7.4.12 aktualisieren
    • Auf 8.0.12 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2013-1397

    Nicht bewertetEPSS 1,62%Korrektur verfügbar

    CVE-2013-1397

    Symfony 2.0.x before 2.0.22, 2.1.x before 2.1.7, and 2.2.x remote attackers to execute arbitrary PHP code via a serialized PHP object to the (1) Yaml::parse or (2) Yaml\Parser::parse function, a different vulnerability than CVE-2013-1348.

    • Auf 2.0.22 aktualisieren
    • Auf 2.1.7 aktualisieren
    • Auf 2.2.0-BETA2 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →