p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de symfony/yaml

Vulnérabilité publiée pour symfony/yaml au cours des 30 derniers jours : 1. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 6

  1. CVE-2026-109413

    Élevée · CVSS 8.7EPSS 0,4%Correctif disponible

    Symfony: Unbounded Recursion in the YAML Inline Lexer Lets a Single Document Crash the Process

    In Symfony YAML prior to versions 5.4.54, 6.4.45, 7.4.18, and 8.1.6, Yaml\Parser::lexInlineStructure() recursed through lexInlineMapping() and lexInlineSequence() for every { and [ of an inline collection, without entering the nesting level that the rest of the parser bounds with maxNestingLevel. A document made of deeply nested inline collections, such as [[[[...]]]], exhausted the stack while it was being lexed: depending on the PHP version and its stack settings, the process crashed or the request ended with a fatal error. Any code parsing untrusted YAML is affected. That includes #[MapRequestPayload] when the Yaml component is installe

    • Mettez à jour vers 5.4.54
    • Mettez à jour vers 6.4.45
    • Mettez à jour vers 7.4.18
    • Mettez à jour vers 8.1.6
    Publication Mise à jour
  2. CVE-2026-45305

    Élevée · CVSS 8.7EPSS 0,68%Correctif disponible

    Symfony: YAML Parser ReDoS via Catastrophic Backtracking in Parser::cleanup() Regex

    Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, Symfony\Component\Yaml\Parser::cleanup() used regular expressions with overlapping quantifiers for YAML directive, comment, and document marker cleanup, allowing crafted input to make parsing hang for an arbitrarily long time. This issue is fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.

    • Mettez à jour vers 5.4.52
    • Mettez à jour vers 6.4.40
    • Mettez à jour vers 7.4.12
    • Mettez à jour vers 8.0.12
    Publication Mise à jour
  3. CVE-2026-45304

    Élevée · CVSS 8.7EPSS 0,68%Correctif disponible

    Symfony: YAML Parser Exponential Memory Allocation via Recursive Collection-Alias Expansion ("Billion Laughs")

    Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, Symfony\Component\Yaml\Parser resolved YAML collection aliases recursively, allowing a small untrusted YAML input to expand into a multi-gigabyte structure and exhaust memory. This issue is fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.

    • Mettez à jour vers 5.4.52
    • Mettez à jour vers 6.4.40
    • Mettez à jour vers 7.4.12
    • Mettez à jour vers 8.0.12
    Publication Mise à jour
  4. CVE-2026-45133

    Élevée · CVSS 8.2EPSS 0,63%Correctif disponible

    Symfony: [Yaml] Harden the parser when handling untrusted input

    Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, when the parser is exposed to attacker-controlled input, deeply nested mappings or sequences cause both the block-level (Parser::parseBlock()) and inline (Inline::parseSequence() / Inline::parseMapping()) parsers to recurse without a depth limit. A crafted document exhausts the PHP stack and crashes the worker. This issue is fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.

    • Mettez à jour vers 5.4.52
    • Mettez à jour vers 6.4.40
    • Mettez à jour vers 7.4.12
    • Mettez à jour vers 8.0.12
    Publication Mise à jour
  5. CVE-2013-1397

    Non évaluéeEPSS 1,62%Correctif disponible

    CVE-2013-1397

    Symfony 2.0.x before 2.0.22, 2.1.x before 2.1.7, and 2.2.x remote attackers to execute arbitrary PHP code via a serialized PHP object to the (1) Yaml::parse or (2) Yaml\Parser::parse function, a different vulnerability than CVE-2013-1348.

    • Mettez à jour vers 2.0.22
    • Mettez à jour vers 2.1.7
    • Mettez à jour vers 2.2.0-BETA2
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →