p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de wp-graphql/wp-graphql

Vulnerabilidades publicadas para wp-graphql/wp-graphql en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 4

  1. CVE-2026-88974

    Media · CVSS 5.4EPSS 0,38%Sin corrección publicada

    WPGraphQL: Contributor can publish and modify posts without the required capabilities via updatePost

    WPGraphQL provides a GraphQL API for WordPress sites. Prior to 2.22.2, the updatePost mutation in src/Mutation/PostObjectUpdate.php checks only the collection-level edit_posts capability and the post author, but does not enforce the object-level edit_post capability or require publish_posts for public status transitions. An authenticated Contributor can therefore publish the Contributor's own draft without editorial approval or modify the Contributor's previously published post despite lacking edit_published_posts, while posts owned by other authors remain protected. This issue is fixed in version 2.22.2.

    Publicación Actualización
  2. CVE-2026-54768

    Media · CVSS 6.9EPSS 0,45%Sin corrección publicada

    WPGraphQL has deprecated `user` field on SendPasswordResetEmailPayload that leaks user existence + profile (defeats explicit anti-enumeration design)

    WPGraphQL provides a GraphQL API for WordPress sites. From 2.0.0 until 2.15.1, the deprecated user field on SendPasswordResetEmailPayload lets an unauthenticated caller distinguish existing author-class accounts through the sendPasswordResetEmail mutation and obtain public profile fields. This issue is fixed in version 2.15.1.

    Publicación Actualización
  3. CVE-2023-23684

    Media · CVSS 4.4EPSS 0,45%Corrección disponible

    WordPress WPGraphQL Plugin <= 1.14.5 is vulnerable to Server Side Request Forgery (SSRF)

    Server-Side Request Forgery (SSRF) vulnerability in WPGraphQL.This issue affects WPGraphQL: from n/a through 1.14.5.

    • Actualiza a 1.14.6
    Publicación Actualización
  4. CVE-2019-25060

    Media · CVSS 5.3EPSS 1,83%Corrección disponible

    WP-GraphQL < 0.3.5 - Improper Access Control

    The WPGraphQL WordPress plugin before 0.3.5 doesn't properly restrict access to information about other users' roles on the affected site. Because of this, a remote attacker could forge a GraphQL query to retrieve the account roles of every user on the site.

    • Actualiza a 0.3.5
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →