p PatchFirst

PatchFirst · Latest vulnerabilities

wp-graphql/wp-graphql vulnerabilities

Vulnerabilities published for wp-graphql/wp-graphql in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 4

  1. CVE-2026-88974

    Medium · CVSS 5.4EPSS 0.38%No fix published

    WPGraphQL: Contributor can publish and modify posts without the required capabilities via updatePost

    WPGraphQL provides a GraphQL API for WordPress sites. Prior to 2.22.2, the updatePost mutation in src/Mutation/PostObjectUpdate.php checks only the collection-level edit_posts capability and the post author, but does not enforce the object-level edit_post capability or require publish_posts for public status transitions. An authenticated Contributor can therefore publish the Contributor's own draft without editorial approval or modify the Contributor's previously published post despite lacking edit_published_posts, while posts owned by other authors remain protected. This issue is fixed in version 2.22.2.

    Published Updated
  2. CVE-2026-54768

    Medium · CVSS 6.9EPSS 0.45%No fix published

    WPGraphQL has deprecated `user` field on SendPasswordResetEmailPayload that leaks user existence + profile (defeats explicit anti-enumeration design)

    WPGraphQL provides a GraphQL API for WordPress sites. From 2.0.0 until 2.15.1, the deprecated user field on SendPasswordResetEmailPayload lets an unauthenticated caller distinguish existing author-class accounts through the sendPasswordResetEmail mutation and obtain public profile fields. This issue is fixed in version 2.15.1.

    Published Updated
  3. CVE-2019-25060

    Medium · CVSS 5.3EPSS 1.83%Fix available

    WP-GraphQL < 0.3.5 - Improper Access Control

    The WPGraphQL WordPress plugin before 0.3.5 doesn't properly restrict access to information about other users' roles on the affected site. Because of this, a remote attacker could forge a GraphQL query to retrieve the account roles of every user on the site.

    • Update to 0.3.5
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →