p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in wp-graphql/wp-graphql

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für wp-graphql/wp-graphql: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 4

  1. CVE-2026-88974

    Mittel · CVSS 5.4EPSS 0,38%Keine Korrektur veröffentlicht

    WPGraphQL: Contributor can publish and modify posts without the required capabilities via updatePost

    WPGraphQL provides a GraphQL API for WordPress sites. Prior to 2.22.2, the updatePost mutation in src/Mutation/PostObjectUpdate.php checks only the collection-level edit_posts capability and the post author, but does not enforce the object-level edit_post capability or require publish_posts for public status transitions. An authenticated Contributor can therefore publish the Contributor's own draft without editorial approval or modify the Contributor's previously published post despite lacking edit_published_posts, while posts owned by other authors remain protected. This issue is fixed in version 2.22.2.

    Veröffentlicht Aktualisiert
  2. CVE-2026-54768

    Mittel · CVSS 6.9EPSS 0,45%Keine Korrektur veröffentlicht

    WPGraphQL has deprecated `user` field on SendPasswordResetEmailPayload that leaks user existence + profile (defeats explicit anti-enumeration design)

    WPGraphQL provides a GraphQL API for WordPress sites. From 2.0.0 until 2.15.1, the deprecated user field on SendPasswordResetEmailPayload lets an unauthenticated caller distinguish existing author-class accounts through the sendPasswordResetEmail mutation and obtain public profile fields. This issue is fixed in version 2.15.1.

    Veröffentlicht Aktualisiert
  3. CVE-2023-23684

    Mittel · CVSS 4.4EPSS 0,45%Korrektur verfügbar

    WordPress WPGraphQL Plugin <= 1.14.5 is vulnerable to Server Side Request Forgery (SSRF)

    Server-Side Request Forgery (SSRF) vulnerability in WPGraphQL.This issue affects WPGraphQL: from n/a through 1.14.5.

    • Auf 1.14.6 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2019-25060

    Mittel · CVSS 5.3EPSS 1,83%Korrektur verfügbar

    WP-GraphQL < 0.3.5 - Improper Access Control

    The WPGraphQL WordPress plugin before 0.3.5 doesn't properly restrict access to information about other users' roles on the affected site. Because of this, a remote attacker could forge a GraphQL query to retrieve the account roles of every user on the site.

    • Auf 0.3.5 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →