p PatchFirst

SUSE-SU-2024:0004-1

SUSE-SU-2024:0004-1 · Security update for webkit2gtk3

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Esta página muestra una selección de datos de las fuentes. Consulte los avisos enlazados para ver la descripción completa y las versiones afectadas.

This update for webkit2gtk3 fixes the following issues: - CVE-2023-42890: Fixed processing malicious web content may lead to arbitrary code execution (bsc#1218033). - CVE-2023-42883: Fixed processing a malicious image may lead to a denial-of-service (bsc#1218032). - CVE-2023-41074: Fixed use-after-free in the MediaRecorder API of the WebKit GStreamer-based ports (bsc#1215870). - CVE-2023-40451, CVE-2023-41074: Update to version 2.42.4 (bsc#1218032, bsc#1215868).

Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • webkit2gtk3-soup2 SUSE:Linux Enterprise Module for Basesystem 15 SP4

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.42.4-150400.4.70.3

    Actualiza a 2.42.4-150400.4.70.3

  • webkit2gtk3-soup2 SUSE:Linux Enterprise Module for Basesystem 15 SP5

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.42.4-150400.4.70.3

    Actualiza a 2.42.4-150400.4.70.3

  • webkit2gtk3 SUSE:Linux Enterprise Module for Desktop Applications 15 SP4

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.42.4-150400.4.70.3

    Actualiza a 2.42.4-150400.4.70.3

  • webkit2gtk3 SUSE:Linux Enterprise Module for Desktop Applications 15 SP5

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.42.4-150400.4.70.3

    Actualiza a 2.42.4-150400.4.70.3

  • webkit2gtk4 SUSE:Linux Enterprise Module for Development Tools 15 SP5

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.42.4-150400.4.70.3

    Actualiza a 2.42.4-150400.4.70.3

  • webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.42.4-150400.4.70.3

    Actualiza a 2.42.4-150400.4.70.3

  • webkit2gtk3-soup2 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.42.4-150400.4.70.3

    Actualiza a 2.42.4-150400.4.70.3

  • webkit2gtk4 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.42.4-150400.4.70.3

    Actualiza a 2.42.4-150400.4.70.3

  • webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.42.4-150400.4.70.3

    Actualiza a 2.42.4-150400.4.70.3

  • webkit2gtk3-soup2 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.42.4-150400.4.70.3

    Actualiza a 2.42.4-150400.4.70.3

  • webkit2gtk4 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.42.4-150400.4.70.3

    Actualiza a 2.42.4-150400.4.70.3

  • webkit2gtk3 SUSE:Linux Enterprise Real Time 15 SP4

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.42.4-150400.4.70.3

    Actualiza a 2.42.4-150400.4.70.3

  • webkit2gtk3-soup2 SUSE:Linux Enterprise Real Time 15 SP4

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.42.4-150400.4.70.3

    Actualiza a 2.42.4-150400.4.70.3

  • webkit2gtk4 SUSE:Linux Enterprise Real Time 15 SP4

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.42.4-150400.4.70.3

    Actualiza a 2.42.4-150400.4.70.3

  • webkit2gtk3 SUSE:Linux Enterprise Server 15 SP4-LTSS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.42.4-150400.4.70.3

    Actualiza a 2.42.4-150400.4.70.3

  • webkit2gtk3-soup2 SUSE:Linux Enterprise Server 15 SP4-LTSS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.42.4-150400.4.70.3

    Actualiza a 2.42.4-150400.4.70.3

  • webkit2gtk4 SUSE:Linux Enterprise Server 15 SP4-LTSS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.42.4-150400.4.70.3

    Actualiza a 2.42.4-150400.4.70.3

  • webkit2gtk3 SUSE:Linux Enterprise Server for SAP Applications 15 SP4

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.42.4-150400.4.70.3

    Actualiza a 2.42.4-150400.4.70.3

  • webkit2gtk3-soup2 SUSE:Linux Enterprise Server for SAP Applications 15 SP4

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.42.4-150400.4.70.3

    Actualiza a 2.42.4-150400.4.70.3

  • webkit2gtk4 SUSE:Linux Enterprise Server for SAP Applications 15 SP4

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.42.4-150400.4.70.3

    Actualiza a 2.42.4-150400.4.70.3

  • webkit2gtk3-soup2 SUSE:Manager Proxy 4.3

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.42.4-150400.4.70.3

    Actualiza a 2.42.4-150400.4.70.3

  • webkit2gtk3-soup2 SUSE:Manager Server 4.3

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.42.4-150400.4.70.3

    Actualiza a 2.42.4-150400.4.70.3

  • webkit2gtk3 openSUSE:Leap 15.4

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.42.4-150400.4.70.3

    Actualiza a 2.42.4-150400.4.70.3

  • webkit2gtk3-soup2 openSUSE:Leap 15.4

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.42.4-150400.4.70.3

    Actualiza a 2.42.4-150400.4.70.3

Fuentes originales

Comprueba tu servidor →