p PatchFirst

SUSE-SU-2024:0004-1

SUSE-SU-2024:0004-1 · Security update for webkit2gtk3

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Diese Seite zeigt ausgewählte Angaben aus den Quellen. Die vollständige Beschreibung und betroffene Versionen finden Sie in den verlinkten Sicherheitshinweisen.

This update for webkit2gtk3 fixes the following issues: - CVE-2023-42890: Fixed processing malicious web content may lead to arbitrary code execution (bsc#1218033). - CVE-2023-42883: Fixed processing a malicious image may lead to a denial-of-service (bsc#1218032). - CVE-2023-41074: Fixed use-after-free in the MediaRecorder API of the WebKit GStreamer-based ports (bsc#1215870). - CVE-2023-40451, CVE-2023-41074: Update to version 2.42.4 (bsc#1218032, bsc#1215868).

Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • webkit2gtk3-soup2 SUSE:Linux Enterprise Module for Basesystem 15 SP4

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.42.4-150400.4.70.3

    Auf 2.42.4-150400.4.70.3 aktualisieren

  • webkit2gtk3-soup2 SUSE:Linux Enterprise Module for Basesystem 15 SP5

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.42.4-150400.4.70.3

    Auf 2.42.4-150400.4.70.3 aktualisieren

  • webkit2gtk3 SUSE:Linux Enterprise Module for Desktop Applications 15 SP4

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.42.4-150400.4.70.3

    Auf 2.42.4-150400.4.70.3 aktualisieren

  • webkit2gtk3 SUSE:Linux Enterprise Module for Desktop Applications 15 SP5

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.42.4-150400.4.70.3

    Auf 2.42.4-150400.4.70.3 aktualisieren

  • webkit2gtk4 SUSE:Linux Enterprise Module for Development Tools 15 SP5

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.42.4-150400.4.70.3

    Auf 2.42.4-150400.4.70.3 aktualisieren

  • webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.42.4-150400.4.70.3

    Auf 2.42.4-150400.4.70.3 aktualisieren

  • webkit2gtk3-soup2 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.42.4-150400.4.70.3

    Auf 2.42.4-150400.4.70.3 aktualisieren

  • webkit2gtk4 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.42.4-150400.4.70.3

    Auf 2.42.4-150400.4.70.3 aktualisieren

  • webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.42.4-150400.4.70.3

    Auf 2.42.4-150400.4.70.3 aktualisieren

  • webkit2gtk3-soup2 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.42.4-150400.4.70.3

    Auf 2.42.4-150400.4.70.3 aktualisieren

  • webkit2gtk4 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.42.4-150400.4.70.3

    Auf 2.42.4-150400.4.70.3 aktualisieren

  • webkit2gtk3 SUSE:Linux Enterprise Real Time 15 SP4

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.42.4-150400.4.70.3

    Auf 2.42.4-150400.4.70.3 aktualisieren

  • webkit2gtk3-soup2 SUSE:Linux Enterprise Real Time 15 SP4

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.42.4-150400.4.70.3

    Auf 2.42.4-150400.4.70.3 aktualisieren

  • webkit2gtk4 SUSE:Linux Enterprise Real Time 15 SP4

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.42.4-150400.4.70.3

    Auf 2.42.4-150400.4.70.3 aktualisieren

  • webkit2gtk3 SUSE:Linux Enterprise Server 15 SP4-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.42.4-150400.4.70.3

    Auf 2.42.4-150400.4.70.3 aktualisieren

  • webkit2gtk3-soup2 SUSE:Linux Enterprise Server 15 SP4-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.42.4-150400.4.70.3

    Auf 2.42.4-150400.4.70.3 aktualisieren

  • webkit2gtk4 SUSE:Linux Enterprise Server 15 SP4-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.42.4-150400.4.70.3

    Auf 2.42.4-150400.4.70.3 aktualisieren

  • webkit2gtk3 SUSE:Linux Enterprise Server for SAP Applications 15 SP4

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.42.4-150400.4.70.3

    Auf 2.42.4-150400.4.70.3 aktualisieren

  • webkit2gtk3-soup2 SUSE:Linux Enterprise Server for SAP Applications 15 SP4

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.42.4-150400.4.70.3

    Auf 2.42.4-150400.4.70.3 aktualisieren

  • webkit2gtk4 SUSE:Linux Enterprise Server for SAP Applications 15 SP4

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.42.4-150400.4.70.3

    Auf 2.42.4-150400.4.70.3 aktualisieren

  • webkit2gtk3-soup2 SUSE:Manager Proxy 4.3

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.42.4-150400.4.70.3

    Auf 2.42.4-150400.4.70.3 aktualisieren

  • webkit2gtk3-soup2 SUSE:Manager Server 4.3

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.42.4-150400.4.70.3

    Auf 2.42.4-150400.4.70.3 aktualisieren

  • webkit2gtk3 openSUSE:Leap 15.4

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.42.4-150400.4.70.3

    Auf 2.42.4-150400.4.70.3 aktualisieren

  • webkit2gtk3-soup2 openSUSE:Leap 15.4

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.42.4-150400.4.70.3

    Auf 2.42.4-150400.4.70.3 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →