SUSE-SU-2024:0004-1
SUSE-SU-2024:0004-1 · Security update for webkit2gtk3
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Cette page présente une partie des faits des sources. Consultez les avis liés pour la description complète et les versions concernées.
This update for webkit2gtk3 fixes the following issues: - CVE-2023-42890: Fixed processing malicious web content may lead to arbitrary code execution (bsc#1218033). - CVE-2023-42883: Fixed processing a malicious image may lead to a denial-of-service (bsc#1218032). - CVE-2023-41074: Fixed use-after-free in the MediaRecorder API of the WebKit GStreamer-based ports (bsc#1215870). - CVE-2023-40451, CVE-2023-41074: Update to version 2.42.4 (bsc#1218032, bsc#1215868).
Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
webkit2gtk3-soup2 SUSE:Linux Enterprise Module for Basesystem 15 SP4
- Plages de versions concernées
- ECOSYSTEM: < 2.42.4-150400.4.70.3
Mettez à jour vers 2.42.4-150400.4.70.3
webkit2gtk3-soup2 SUSE:Linux Enterprise Module for Basesystem 15 SP5
- Plages de versions concernées
- ECOSYSTEM: < 2.42.4-150400.4.70.3
Mettez à jour vers 2.42.4-150400.4.70.3
webkit2gtk3 SUSE:Linux Enterprise Module for Desktop Applications 15 SP4
- Plages de versions concernées
- ECOSYSTEM: < 2.42.4-150400.4.70.3
Mettez à jour vers 2.42.4-150400.4.70.3
webkit2gtk3 SUSE:Linux Enterprise Module for Desktop Applications 15 SP5
- Plages de versions concernées
- ECOSYSTEM: < 2.42.4-150400.4.70.3
Mettez à jour vers 2.42.4-150400.4.70.3
webkit2gtk4 SUSE:Linux Enterprise Module for Development Tools 15 SP5
- Plages de versions concernées
- ECOSYSTEM: < 2.42.4-150400.4.70.3
Mettez à jour vers 2.42.4-150400.4.70.3
webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS
- Plages de versions concernées
- ECOSYSTEM: < 2.42.4-150400.4.70.3
Mettez à jour vers 2.42.4-150400.4.70.3
webkit2gtk3-soup2 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS
- Plages de versions concernées
- ECOSYSTEM: < 2.42.4-150400.4.70.3
Mettez à jour vers 2.42.4-150400.4.70.3
webkit2gtk4 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS
- Plages de versions concernées
- ECOSYSTEM: < 2.42.4-150400.4.70.3
Mettez à jour vers 2.42.4-150400.4.70.3
webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS
- Plages de versions concernées
- ECOSYSTEM: < 2.42.4-150400.4.70.3
Mettez à jour vers 2.42.4-150400.4.70.3
webkit2gtk3-soup2 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS
- Plages de versions concernées
- ECOSYSTEM: < 2.42.4-150400.4.70.3
Mettez à jour vers 2.42.4-150400.4.70.3
webkit2gtk4 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS
- Plages de versions concernées
- ECOSYSTEM: < 2.42.4-150400.4.70.3
Mettez à jour vers 2.42.4-150400.4.70.3
webkit2gtk3 SUSE:Linux Enterprise Real Time 15 SP4
- Plages de versions concernées
- ECOSYSTEM: < 2.42.4-150400.4.70.3
Mettez à jour vers 2.42.4-150400.4.70.3
webkit2gtk3-soup2 SUSE:Linux Enterprise Real Time 15 SP4
- Plages de versions concernées
- ECOSYSTEM: < 2.42.4-150400.4.70.3
Mettez à jour vers 2.42.4-150400.4.70.3
webkit2gtk4 SUSE:Linux Enterprise Real Time 15 SP4
- Plages de versions concernées
- ECOSYSTEM: < 2.42.4-150400.4.70.3
Mettez à jour vers 2.42.4-150400.4.70.3
webkit2gtk3 SUSE:Linux Enterprise Server 15 SP4-LTSS
- Plages de versions concernées
- ECOSYSTEM: < 2.42.4-150400.4.70.3
Mettez à jour vers 2.42.4-150400.4.70.3
webkit2gtk3-soup2 SUSE:Linux Enterprise Server 15 SP4-LTSS
- Plages de versions concernées
- ECOSYSTEM: < 2.42.4-150400.4.70.3
Mettez à jour vers 2.42.4-150400.4.70.3
webkit2gtk4 SUSE:Linux Enterprise Server 15 SP4-LTSS
- Plages de versions concernées
- ECOSYSTEM: < 2.42.4-150400.4.70.3
Mettez à jour vers 2.42.4-150400.4.70.3
webkit2gtk3 SUSE:Linux Enterprise Server for SAP Applications 15 SP4
- Plages de versions concernées
- ECOSYSTEM: < 2.42.4-150400.4.70.3
Mettez à jour vers 2.42.4-150400.4.70.3
webkit2gtk3-soup2 SUSE:Linux Enterprise Server for SAP Applications 15 SP4
- Plages de versions concernées
- ECOSYSTEM: < 2.42.4-150400.4.70.3
Mettez à jour vers 2.42.4-150400.4.70.3
webkit2gtk4 SUSE:Linux Enterprise Server for SAP Applications 15 SP4
- Plages de versions concernées
- ECOSYSTEM: < 2.42.4-150400.4.70.3
Mettez à jour vers 2.42.4-150400.4.70.3
webkit2gtk3-soup2 SUSE:Manager Proxy 4.3
- Plages de versions concernées
- ECOSYSTEM: < 2.42.4-150400.4.70.3
Mettez à jour vers 2.42.4-150400.4.70.3
webkit2gtk3-soup2 SUSE:Manager Server 4.3
- Plages de versions concernées
- ECOSYSTEM: < 2.42.4-150400.4.70.3
Mettez à jour vers 2.42.4-150400.4.70.3
webkit2gtk3 openSUSE:Leap 15.4
- Plages de versions concernées
- ECOSYSTEM: < 2.42.4-150400.4.70.3
Mettez à jour vers 2.42.4-150400.4.70.3
webkit2gtk3-soup2 openSUSE:Leap 15.4
- Plages de versions concernées
- ECOSYSTEM: < 2.42.4-150400.4.70.3
Mettez à jour vers 2.42.4-150400.4.70.3
Sources originales
- https://www.suse.com/support/update/announcement/2024/suse-su-20240004-1/
- https://bugzilla.suse.com/1215868
- https://bugzilla.suse.com/1215869
- https://bugzilla.suse.com/1215870
- https://bugzilla.suse.com/1218032
- https://bugzilla.suse.com/1218033
- https://www.suse.com/security/cve/CVE-2023-32359
- https://www.suse.com/security/cve/CVE-2023-39928
- https://www.suse.com/security/cve/CVE-2023-40451
- https://www.suse.com/security/cve/CVE-2023-41074
- https://www.suse.com/security/cve/CVE-2023-42883
- https://www.suse.com/security/cve/CVE-2023-42890
- https://osv.dev/vulnerability/SUSE-SU-2024:0004-1