p PatchFirst

SUSE-SU-2024:1144-1

SUSE-SU-2024:1144-1 · Security update for buildah

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Esta página muestra una selección de datos de las fuentes. Consulte los avisos enlazados para ver la descripción completa y las versiones afectadas.

This update for buildah fixes the following issues: - CVE-2024-1753: Fixed an issue to prevent a full container escape at build time. (bsc#1221677) - Update to version 1.34.1 for compatibility with Docker 25.0 (which is not in SLES yet, but will eventually be) (bsc#1219563). See the corresponding release notes: * https://github.com/containers/buildah/releases/tag/v1.34.1 * https://github.com/containers/buildah/releases/tag/v1.34.0 * https://github.com/containers/buildah/releases/tag/v1.33.0 * https://github.com/containers/buildah/releases/tag/v1.32.0 * https://github.com/containers/buildah/releases/tag/v1.31.0 * https://github.com/containers/buildah/releases/tag/v1.30.0 - Require cni-plugins (bsc#1220568)

Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • cni SUSE:Linux Enterprise Micro 5.3

    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.7.1-150100.3.18.1

    Actualiza a 0.7.1-150100.3.18.1

  • cni-plugins SUSE:Linux Enterprise Micro 5.3

    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.8.6-150100.3.22.3

    Actualiza a 0.8.6-150100.3.22.3

  • cni SUSE:Linux Enterprise Micro 5.4

    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.7.1-150100.3.18.1

    Actualiza a 0.7.1-150100.3.18.1

  • cni-plugins SUSE:Linux Enterprise Micro 5.4

    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.8.6-150100.3.22.3

    Actualiza a 0.8.6-150100.3.22.3

  • cni SUSE:Linux Enterprise Module for Public Cloud 15 SP2

    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.7.1-150100.3.18.1

    Actualiza a 0.7.1-150100.3.18.1

  • cni-plugins SUSE:Linux Enterprise Module for Public Cloud 15 SP2

    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.8.6-150100.3.22.3

    Actualiza a 0.8.6-150100.3.22.3

  • cni SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.7.1-150100.3.18.1

    Actualiza a 0.7.1-150100.3.18.1

  • cni-plugins SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.8.6-150100.3.22.3

    Actualiza a 0.8.6-150100.3.22.3

  • cni SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.7.1-150100.3.18.1

    Actualiza a 0.7.1-150100.3.18.1

  • cni-plugins SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.8.6-150100.3.22.3

    Actualiza a 0.8.6-150100.3.22.3

  • buildah SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.34.1-150400.3.27.1

    Actualiza a 1.34.1-150400.3.27.1

  • cni SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.7.1-150100.3.18.1

    Actualiza a 0.7.1-150100.3.18.1

  • cni-plugins SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.8.6-150100.3.22.3

    Actualiza a 0.8.6-150100.3.22.3

  • buildah SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.34.1-150400.3.27.1

    Actualiza a 1.34.1-150400.3.27.1

  • cni SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.7.1-150100.3.18.1

    Actualiza a 0.7.1-150100.3.18.1

  • cni-plugins SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.8.6-150100.3.22.3

    Actualiza a 0.8.6-150100.3.22.3

  • cni SUSE:Linux Enterprise Server 15 SP2-LTSS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.7.1-150100.3.18.1

    Actualiza a 0.7.1-150100.3.18.1

  • cni-plugins SUSE:Linux Enterprise Server 15 SP2-LTSS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.8.6-150100.3.22.3

    Actualiza a 0.8.6-150100.3.22.3

  • cni SUSE:Linux Enterprise Server 15 SP3-LTSS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.7.1-150100.3.18.1

    Actualiza a 0.7.1-150100.3.18.1

  • cni-plugins SUSE:Linux Enterprise Server 15 SP3-LTSS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.8.6-150100.3.22.3

    Actualiza a 0.8.6-150100.3.22.3

  • buildah SUSE:Linux Enterprise Server 15 SP4-LTSS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.34.1-150400.3.27.1

    Actualiza a 1.34.1-150400.3.27.1

  • cni SUSE:Linux Enterprise Server 15 SP4-LTSS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.7.1-150100.3.18.1

    Actualiza a 0.7.1-150100.3.18.1

  • cni-plugins SUSE:Linux Enterprise Server 15 SP4-LTSS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.8.6-150100.3.22.3

    Actualiza a 0.8.6-150100.3.22.3

  • cni SUSE:Linux Enterprise Server for SAP Applications 15 SP2

    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.7.1-150100.3.18.1

    Actualiza a 0.7.1-150100.3.18.1

Fuentes originales

Comprueba tu servidor →