p PatchFirst

SUSE-SU-2024:1144-1

SUSE-SU-2024:1144-1 · Security update for buildah

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Diese Seite zeigt ausgewählte Angaben aus den Quellen. Die vollständige Beschreibung und betroffene Versionen finden Sie in den verlinkten Sicherheitshinweisen.

This update for buildah fixes the following issues: - CVE-2024-1753: Fixed an issue to prevent a full container escape at build time. (bsc#1221677) - Update to version 1.34.1 for compatibility with Docker 25.0 (which is not in SLES yet, but will eventually be) (bsc#1219563). See the corresponding release notes: * https://github.com/containers/buildah/releases/tag/v1.34.1 * https://github.com/containers/buildah/releases/tag/v1.34.0 * https://github.com/containers/buildah/releases/tag/v1.33.0 * https://github.com/containers/buildah/releases/tag/v1.32.0 * https://github.com/containers/buildah/releases/tag/v1.31.0 * https://github.com/containers/buildah/releases/tag/v1.30.0 - Require cni-plugins (bsc#1220568)

Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • cni SUSE:Linux Enterprise Micro 5.3

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.7.1-150100.3.18.1

    Auf 0.7.1-150100.3.18.1 aktualisieren

  • cni-plugins SUSE:Linux Enterprise Micro 5.3

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.8.6-150100.3.22.3

    Auf 0.8.6-150100.3.22.3 aktualisieren

  • cni SUSE:Linux Enterprise Micro 5.4

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.7.1-150100.3.18.1

    Auf 0.7.1-150100.3.18.1 aktualisieren

  • cni-plugins SUSE:Linux Enterprise Micro 5.4

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.8.6-150100.3.22.3

    Auf 0.8.6-150100.3.22.3 aktualisieren

  • cni SUSE:Linux Enterprise Module for Public Cloud 15 SP2

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.7.1-150100.3.18.1

    Auf 0.7.1-150100.3.18.1 aktualisieren

  • cni-plugins SUSE:Linux Enterprise Module for Public Cloud 15 SP2

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.8.6-150100.3.22.3

    Auf 0.8.6-150100.3.22.3 aktualisieren

  • cni SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.7.1-150100.3.18.1

    Auf 0.7.1-150100.3.18.1 aktualisieren

  • cni-plugins SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.8.6-150100.3.22.3

    Auf 0.8.6-150100.3.22.3 aktualisieren

  • cni SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.7.1-150100.3.18.1

    Auf 0.7.1-150100.3.18.1 aktualisieren

  • cni-plugins SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.8.6-150100.3.22.3

    Auf 0.8.6-150100.3.22.3 aktualisieren

  • buildah SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.34.1-150400.3.27.1

    Auf 1.34.1-150400.3.27.1 aktualisieren

  • cni SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.7.1-150100.3.18.1

    Auf 0.7.1-150100.3.18.1 aktualisieren

  • cni-plugins SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.8.6-150100.3.22.3

    Auf 0.8.6-150100.3.22.3 aktualisieren

  • buildah SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.34.1-150400.3.27.1

    Auf 1.34.1-150400.3.27.1 aktualisieren

  • cni SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.7.1-150100.3.18.1

    Auf 0.7.1-150100.3.18.1 aktualisieren

  • cni-plugins SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.8.6-150100.3.22.3

    Auf 0.8.6-150100.3.22.3 aktualisieren

  • cni SUSE:Linux Enterprise Server 15 SP2-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.7.1-150100.3.18.1

    Auf 0.7.1-150100.3.18.1 aktualisieren

  • cni-plugins SUSE:Linux Enterprise Server 15 SP2-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.8.6-150100.3.22.3

    Auf 0.8.6-150100.3.22.3 aktualisieren

  • cni SUSE:Linux Enterprise Server 15 SP3-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.7.1-150100.3.18.1

    Auf 0.7.1-150100.3.18.1 aktualisieren

  • cni-plugins SUSE:Linux Enterprise Server 15 SP3-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.8.6-150100.3.22.3

    Auf 0.8.6-150100.3.22.3 aktualisieren

  • buildah SUSE:Linux Enterprise Server 15 SP4-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.34.1-150400.3.27.1

    Auf 1.34.1-150400.3.27.1 aktualisieren

  • cni SUSE:Linux Enterprise Server 15 SP4-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.7.1-150100.3.18.1

    Auf 0.7.1-150100.3.18.1 aktualisieren

  • cni-plugins SUSE:Linux Enterprise Server 15 SP4-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.8.6-150100.3.22.3

    Auf 0.8.6-150100.3.22.3 aktualisieren

  • cni SUSE:Linux Enterprise Server for SAP Applications 15 SP2

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.7.1-150100.3.18.1

    Auf 0.7.1-150100.3.18.1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →