SUSE-SU-2024:1144-1
SUSE-SU-2024:1144-1 · Security update for buildah
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This page shows selected source facts. See the linked advisories for the complete description and affected versions.
This update for buildah fixes the following issues: - CVE-2024-1753: Fixed an issue to prevent a full container escape at build time. (bsc#1221677) - Update to version 1.34.1 for compatibility with Docker 25.0 (which is not in SLES yet, but will eventually be) (bsc#1219563). See the corresponding release notes: * https://github.com/containers/buildah/releases/tag/v1.34.1 * https://github.com/containers/buildah/releases/tag/v1.34.0 * https://github.com/containers/buildah/releases/tag/v1.33.0 * https://github.com/containers/buildah/releases/tag/v1.32.0 * https://github.com/containers/buildah/releases/tag/v1.31.0 * https://github.com/containers/buildah/releases/tag/v1.30.0 - Require cni-plugins (bsc#1220568)
Fix available
- Published
- Updated
Stack: system
Affected products and versions
cni SUSE:Linux Enterprise Micro 5.3
- Affected ranges
- ECOSYSTEM: < 0.7.1-150100.3.18.1
Update to 0.7.1-150100.3.18.1
cni-plugins SUSE:Linux Enterprise Micro 5.3
- Affected ranges
- ECOSYSTEM: < 0.8.6-150100.3.22.3
Update to 0.8.6-150100.3.22.3
cni SUSE:Linux Enterprise Micro 5.4
- Affected ranges
- ECOSYSTEM: < 0.7.1-150100.3.18.1
Update to 0.7.1-150100.3.18.1
cni-plugins SUSE:Linux Enterprise Micro 5.4
- Affected ranges
- ECOSYSTEM: < 0.8.6-150100.3.22.3
Update to 0.8.6-150100.3.22.3
cni SUSE:Linux Enterprise Module for Public Cloud 15 SP2
- Affected ranges
- ECOSYSTEM: < 0.7.1-150100.3.18.1
Update to 0.7.1-150100.3.18.1
cni-plugins SUSE:Linux Enterprise Module for Public Cloud 15 SP2
- Affected ranges
- ECOSYSTEM: < 0.8.6-150100.3.22.3
Update to 0.8.6-150100.3.22.3
cni SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS
- Affected ranges
- ECOSYSTEM: < 0.7.1-150100.3.18.1
Update to 0.7.1-150100.3.18.1
cni-plugins SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS
- Affected ranges
- ECOSYSTEM: < 0.8.6-150100.3.22.3
Update to 0.8.6-150100.3.22.3
cni SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS
- Affected ranges
- ECOSYSTEM: < 0.7.1-150100.3.18.1
Update to 0.7.1-150100.3.18.1
cni-plugins SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS
- Affected ranges
- ECOSYSTEM: < 0.8.6-150100.3.22.3
Update to 0.8.6-150100.3.22.3
buildah SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS
- Affected ranges
- ECOSYSTEM: < 1.34.1-150400.3.27.1
Update to 1.34.1-150400.3.27.1
cni SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS
- Affected ranges
- ECOSYSTEM: < 0.7.1-150100.3.18.1
Update to 0.7.1-150100.3.18.1
cni-plugins SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS
- Affected ranges
- ECOSYSTEM: < 0.8.6-150100.3.22.3
Update to 0.8.6-150100.3.22.3
buildah SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS
- Affected ranges
- ECOSYSTEM: < 1.34.1-150400.3.27.1
Update to 1.34.1-150400.3.27.1
cni SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS
- Affected ranges
- ECOSYSTEM: < 0.7.1-150100.3.18.1
Update to 0.7.1-150100.3.18.1
cni-plugins SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS
- Affected ranges
- ECOSYSTEM: < 0.8.6-150100.3.22.3
Update to 0.8.6-150100.3.22.3
cni SUSE:Linux Enterprise Server 15 SP2-LTSS
- Affected ranges
- ECOSYSTEM: < 0.7.1-150100.3.18.1
Update to 0.7.1-150100.3.18.1
cni-plugins SUSE:Linux Enterprise Server 15 SP2-LTSS
- Affected ranges
- ECOSYSTEM: < 0.8.6-150100.3.22.3
Update to 0.8.6-150100.3.22.3
cni SUSE:Linux Enterprise Server 15 SP3-LTSS
- Affected ranges
- ECOSYSTEM: < 0.7.1-150100.3.18.1
Update to 0.7.1-150100.3.18.1
cni-plugins SUSE:Linux Enterprise Server 15 SP3-LTSS
- Affected ranges
- ECOSYSTEM: < 0.8.6-150100.3.22.3
Update to 0.8.6-150100.3.22.3
buildah SUSE:Linux Enterprise Server 15 SP4-LTSS
- Affected ranges
- ECOSYSTEM: < 1.34.1-150400.3.27.1
Update to 1.34.1-150400.3.27.1
cni SUSE:Linux Enterprise Server 15 SP4-LTSS
- Affected ranges
- ECOSYSTEM: < 0.7.1-150100.3.18.1
Update to 0.7.1-150100.3.18.1
cni-plugins SUSE:Linux Enterprise Server 15 SP4-LTSS
- Affected ranges
- ECOSYSTEM: < 0.8.6-150100.3.22.3
Update to 0.8.6-150100.3.22.3
cni SUSE:Linux Enterprise Server for SAP Applications 15 SP2
- Affected ranges
- ECOSYSTEM: < 0.7.1-150100.3.18.1
Update to 0.7.1-150100.3.18.1