p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de qt4-x11

Vulnerabilidades publicadas para qt4-x11 en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 19

  1. CVE-2026-15037

    Baja · CVSS 2.9EPSS 0,44%Sin corrección publicada

    XML injection vulnerability in QDom comment, CDATA and processing-instruction serialization

    Improper output neutralization (XML injection) in QDom comment, CDATA, and processing-instruction serialization in Qt XML from 4.0.0 through 6.11 allows untrusted text serialized by an application into those nodes to inject arbitrary XML markup, because the node terminators are not escaped under the default InvalidDataPolicy (AcceptInvalidChars). Fixed in Qt 6.12.

    Publicación Actualización
  2. CVE-2023-43114

    Media · CVSS 5.5EPSS 0,27%Sin corrección publicada

    CVE-2023-43114

    An issue was discovered in Qt before 5.15.16, 6.x before 6.2.10, and 6.3.x through 6.5.x before 6.5.3 on Windows. When using the GDI font engine, if a corrupted font is loaded via QFontDatabase::addApplicationFont{FromData], then it can cause the application to crash because of missing length checks.

    Publicación Actualización
  3. CVE-2021-3481

    Alta · CVSS 7.1EPSS 0,54%Sin corrección publicada

    CVE-2021-3481

    A flaw was found in Qt. An out-of-bounds read vulnerability was found in QRadialFetchSimd in qt/qtbase/src/gui/painting/qdrawhelper_p.h in Qt/Qtbase. While rendering and displaying a crafted Scalable Vector Graphics (SVG) file this flaw may lead to an unauthorized memory access. The highest threat from this vulnerability is to data confidentiality and the application availability.

    Publicación Actualización
  4. CVE-2015-1860

    Sin evaluarEPSS 8,34%Corrección disponible

    CVE-2015-1860

    Multiple buffer overflows in gui/image/qgifhandler.cpp in the QtBase module in Qt before 4.8.7 and 5.x before 5.4.2 allow remote attackers to cause a denial of service (segmentation fault) and possibly execute arbitrary code via a crafted GIF image.

    • Actualiza a 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1
    Publicación Actualización
  5. CVE-2015-1859

    Sin evaluarEPSS 6,54%Corrección disponible

    CVE-2015-1859

    Multiple buffer overflows in plugins/imageformats/ico/qicohandler.cpp in the QtBase module in Qt before 4.8.7 and 5.x before 5.4.2 allow remote attackers to cause a denial of service (segmentation fault and crash) and possibly execute arbitrary code via a crafted ICO image.

    • Actualiza a 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1
    Publicación Actualización
  6. CVE-2015-1858

    Sin evaluarEPSS 6,57%Corrección disponible

    CVE-2015-1858

    Multiple buffer overflows in gui/image/qbmphandler.cpp in the QtBase module in Qt before 4.8.7 and 5.x before 5.4.2 allow remote attackers to cause a denial of service (segmentation fault and crash) and possibly execute arbitrary code via a crafted BMP image.

    • Actualiza a 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1
    Publicación Actualización
  7. CVE-2015-0295

    Sin evaluarEPSS 6,07%Corrección disponible

    CVE-2015-0295

    The BMP decoder in QtGui in QT before 5.5 does not properly calculate the masks used to extract the color components, which allows remote attackers to cause a denial of service (divide-by-zero and crash) via a crafted BMP file.

    • Actualiza a 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →