p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in qt4-x11

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für qt4-x11: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 19

  1. CVE-2026-15037

    Niedrig · CVSS 2.9EPSS 0,44%Keine Korrektur veröffentlicht

    XML injection vulnerability in QDom comment, CDATA and processing-instruction serialization

    Improper output neutralization (XML injection) in QDom comment, CDATA, and processing-instruction serialization in Qt XML from 4.0.0 through 6.11 allows untrusted text serialized by an application into those nodes to inject arbitrary XML markup, because the node terminators are not escaped under the default InvalidDataPolicy (AcceptInvalidChars). Fixed in Qt 6.12.

    Veröffentlicht Aktualisiert
  2. CVE-2023-43114

    Mittel · CVSS 5.5EPSS 0,27%Keine Korrektur veröffentlicht

    CVE-2023-43114

    An issue was discovered in Qt before 5.15.16, 6.x before 6.2.10, and 6.3.x through 6.5.x before 6.5.3 on Windows. When using the GDI font engine, if a corrupted font is loaded via QFontDatabase::addApplicationFont{FromData], then it can cause the application to crash because of missing length checks.

    Veröffentlicht Aktualisiert
  3. CVE-2021-3481

    Hoch · CVSS 7.1EPSS 0,54%Keine Korrektur veröffentlicht

    CVE-2021-3481

    A flaw was found in Qt. An out-of-bounds read vulnerability was found in QRadialFetchSimd in qt/qtbase/src/gui/painting/qdrawhelper_p.h in Qt/Qtbase. While rendering and displaying a crafted Scalable Vector Graphics (SVG) file this flaw may lead to an unauthorized memory access. The highest threat from this vulnerability is to data confidentiality and the application availability.

    Veröffentlicht Aktualisiert
  4. CVE-2015-1860

    Nicht bewertetEPSS 8,34%Korrektur verfügbar

    CVE-2015-1860

    Multiple buffer overflows in gui/image/qgifhandler.cpp in the QtBase module in Qt before 4.8.7 and 5.x before 5.4.2 allow remote attackers to cause a denial of service (segmentation fault) and possibly execute arbitrary code via a crafted GIF image.

    • Auf 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1 aktualisieren
    Veröffentlicht Aktualisiert
  5. CVE-2015-1859

    Nicht bewertetEPSS 6,54%Korrektur verfügbar

    CVE-2015-1859

    Multiple buffer overflows in plugins/imageformats/ico/qicohandler.cpp in the QtBase module in Qt before 4.8.7 and 5.x before 5.4.2 allow remote attackers to cause a denial of service (segmentation fault and crash) and possibly execute arbitrary code via a crafted ICO image.

    • Auf 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1 aktualisieren
    Veröffentlicht Aktualisiert
  6. CVE-2015-1858

    Nicht bewertetEPSS 6,57%Korrektur verfügbar

    CVE-2015-1858

    Multiple buffer overflows in gui/image/qbmphandler.cpp in the QtBase module in Qt before 4.8.7 and 5.x before 5.4.2 allow remote attackers to cause a denial of service (segmentation fault and crash) and possibly execute arbitrary code via a crafted BMP image.

    • Auf 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1 aktualisieren
    Veröffentlicht Aktualisiert
  7. CVE-2015-0295

    Nicht bewertetEPSS 6,07%Korrektur verfügbar

    CVE-2015-0295

    The BMP decoder in QtGui in QT before 5.5 does not properly calculate the masks used to extract the color components, which allows remote attackers to cause a denial of service (divide-by-zero and crash) via a crafted BMP file.

    • Auf 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →