p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de qt4-x11

Vulnérabilité publiée pour qt4-x11 au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 19

  1. CVE-2026-15037

    Faible · CVSS 2.9EPSS 0,44%Aucun correctif publié

    XML injection vulnerability in QDom comment, CDATA and processing-instruction serialization

    Improper output neutralization (XML injection) in QDom comment, CDATA, and processing-instruction serialization in Qt XML from 4.0.0 through 6.11 allows untrusted text serialized by an application into those nodes to inject arbitrary XML markup, because the node terminators are not escaped under the default InvalidDataPolicy (AcceptInvalidChars). Fixed in Qt 6.12.

    Publication Mise à jour
  2. CVE-2023-43114

    Moyenne · CVSS 5.5EPSS 0,27%Aucun correctif publié

    CVE-2023-43114

    An issue was discovered in Qt before 5.15.16, 6.x before 6.2.10, and 6.3.x through 6.5.x before 6.5.3 on Windows. When using the GDI font engine, if a corrupted font is loaded via QFontDatabase::addApplicationFont{FromData], then it can cause the application to crash because of missing length checks.

    Publication Mise à jour
  3. CVE-2021-3481

    Élevée · CVSS 7.1EPSS 0,54%Aucun correctif publié

    CVE-2021-3481

    A flaw was found in Qt. An out-of-bounds read vulnerability was found in QRadialFetchSimd in qt/qtbase/src/gui/painting/qdrawhelper_p.h in Qt/Qtbase. While rendering and displaying a crafted Scalable Vector Graphics (SVG) file this flaw may lead to an unauthorized memory access. The highest threat from this vulnerability is to data confidentiality and the application availability.

    Publication Mise à jour
  4. CVE-2015-1860

    Non évaluéeEPSS 8,34%Correctif disponible

    CVE-2015-1860

    Multiple buffer overflows in gui/image/qgifhandler.cpp in the QtBase module in Qt before 4.8.7 and 5.x before 5.4.2 allow remote attackers to cause a denial of service (segmentation fault) and possibly execute arbitrary code via a crafted GIF image.

    • Mettez à jour vers 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1
    Publication Mise à jour
  5. CVE-2015-1859

    Non évaluéeEPSS 6,54%Correctif disponible

    CVE-2015-1859

    Multiple buffer overflows in plugins/imageformats/ico/qicohandler.cpp in the QtBase module in Qt before 4.8.7 and 5.x before 5.4.2 allow remote attackers to cause a denial of service (segmentation fault and crash) and possibly execute arbitrary code via a crafted ICO image.

    • Mettez à jour vers 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1
    Publication Mise à jour
  6. CVE-2015-1858

    Non évaluéeEPSS 6,57%Correctif disponible

    CVE-2015-1858

    Multiple buffer overflows in gui/image/qbmphandler.cpp in the QtBase module in Qt before 4.8.7 and 5.x before 5.4.2 allow remote attackers to cause a denial of service (segmentation fault and crash) and possibly execute arbitrary code via a crafted BMP image.

    • Mettez à jour vers 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →