p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de trafficserver · Página 6

Vulnerabilidades publicadas para trafficserver en los últimos 30 días: 16. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 111

  1. CVE-2019-10079

    Alta · CVSS 7.5EPSS 4,56%Sin corrección publicada

    CVE-2019-10079

    Apache Traffic Server is vulnerable to HTTP/2 setting flood attacks. Earlier versions of Apache Traffic Server didn't limit the number of setting frames sent from the client using the HTTP/2 protocol. Users should upgrade to Apache Traffic Server 7.1.7, 8.0.4, or later versions.

    Publicación Actualización
  2. CVE-2019-9518

    Alta · CVSS 7.5EPSS 25,45%Sin corrección publicada

    Some HTTP/2 implementations are vulnerable to a flood of empty frames, potentially leading to a denial of service

    Some HTTP/2 implementations are vulnerable to a flood of empty frames, potentially leading to a denial of service. The attacker sends a stream of frames with an empty payload and without the end-of-stream flag. These frames can be DATA, HEADERS, CONTINUATION and/or PUSH_PROMISE. The peer spends time processing each frame disproportionate to attack bandwidth. This can consume excess CPU.

    Publicación Actualización
  3. CVE-2019-9515

    Alta · CVSS 7.5EPSS 87,29%Sin corrección publicada

    Some HTTP/2 implementations are vulnerable to a settings flood, potentially leading to a denial of service

    Some HTTP/2 implementations are vulnerable to a settings flood, potentially leading to a denial of service. The attacker sends a stream of SETTINGS frames to the peer. Since the RFC requires that the peer reply with one acknowledgement per SETTINGS frame, an empty SETTINGS frame is almost equivalent in behavior to a ping. Depending on how efficiently this data is queued, this can consume excess CPU, memory, or both.

    Publicación Actualización
  4. CVE-2019-9512

    Alta · CVSS 7.5EPSS 83,43%Sin corrección publicada

    Some HTTP/2 implementations are vulnerable to ping floods, potentially leading to a denial of service

    Some HTTP/2 implementations are vulnerable to ping floods, potentially leading to a denial of service. The attacker sends continual pings to an HTTP/2 peer, causing the peer to build an internal queue of responses. Depending on how efficiently this data is queued, this can consume excess CPU, memory, or both.

    Publicación Actualización
  5. CVE-2019-9514

    Alta · CVSS 7.5EPSS 82,81%Sin corrección publicada

    Some HTTP/2 implementations are vulnerable to a reset flood, potentially leading to a denial of service

    Some HTTP/2 implementations are vulnerable to a reset flood, potentially leading to a denial of service. The attacker opens a number of streams and sends an invalid request over each stream that should solicit a stream of RST_STREAM frames from the peer. Depending on how the peer queues the RST_STREAM frames, this can consume excess memory, CPU, or both.

    Publicación Actualización
  6. CVE-2018-11783

    Alta · CVSS 7.5EPSS 1,87%Sin corrección publicada

    CVE-2018-11783

    sslheaders plugin extracts information from the client certificate and sets headers in the request based on the configuration of the plugin. The plugin doesn't strip the headers from the request in some scenarios. This problem was discovered in versions 6.0.0 to 6.0.3, 7.0.0 to 7.1.5, and 8.0.0 to 8.0.1.

    Publicación Actualización
  7. CVE-2018-8040

    Media · CVSS 5.3EPSS 7,17%Sin corrección publicada

    CVE-2018-8040

    Pages that are rendered using the ESI plugin can have access to the cookie header when the plugin is configured not to allow access. This affects Apache Traffic Server (ATS) versions 6.0.0 to 6.2.2 and 7.0.0 to 7.1.3. To resolve this issue users running 6.x should upgrade to 6.2.3 or later versions and 7.x users should upgrade to 7.1.4 or later versions.

    Publicación Actualización
  8. CVE-2018-8005

    Media · CVSS 5.3EPSS 6,89%Sin corrección publicada

    CVE-2018-8005

    When there are multiple ranges in a range request, Apache Traffic Server (ATS) will read the entire object from cache. This can cause performance problems with large objects in cache. This affects versions 6.0.0 to 6.2.2 and 7.0.0 to 7.1.3. To resolve this issue users running 6.x users should upgrade to 6.2.3 or later versions and 7.x users should upgrade to 7.1.4 or later versions.

    Publicación Actualización
  9. CVE-2018-8004

    Media · CVSS 6.5EPSS 6,31%Sin corrección publicada

    CVE-2018-8004

    There are multiple HTTP smuggling and cache poisoning issues when clients making malicious requests interact with Apache Traffic Server (ATS). This affects versions 6.0.0 to 6.2.2 and 7.0.0 to 7.1.3. To resolve this issue users running 6.x should upgrade to 6.2.3 or later versions and 7.x users should upgrade to 7.1.4 or later versions.

    Publicación Actualización
  10. CVE-2018-1318

    Alta · CVSS 7.5EPSS 7,72%Sin corrección publicada

    CVE-2018-1318

    Adding method ACLs in remap.config can cause a segfault when the user makes a carefully crafted request. This affects versions Apache Traffic Server (ATS) 6.0.0 to 6.2.2 and 7.0.0 to 7.1.3. To resolve this issue users running 6.x should upgrade to 6.2.3 or later versions and 7.x users should upgrade to 7.1.4 or later versions.

    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →