p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de node-express

Vulnerabilidades publicadas para node-express en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 3

  1. CVE-2024-43796

    Media · CVSS 5EPSS 0,49%Corrección disponible

    express vulnerable to XSS via response.redirect()

    Express.js minimalist web framework for node. In express < 4.20.0, passing untrusted user input - even after sanitizing it - to response.redirect() may execute untrusted code. This issue is patched in express 4.20.0.

    • Actualiza a 4.17.1-2ubuntu0.1~esm1
    Publicación Actualización
  2. CVE-2024-29041

    Media · CVSS 6.1EPSS 0,79%Corrección disponible

    Express.js Open Redirect in malformed URLs

    Express.js minimalist web framework for node. Versions of Express.js prior to 4.19.0 and all pre-release alpha and beta versions of 5.0 are affected by an open redirect vulnerability using malformed URLs. When a user of Express performs a redirect using a user-provided URL Express performs an encode [using `encodeurl`](https://github.com/pillarjs/encodeurl) on the contents before passing it to the `location` header. This can cause malformed URLs to be evaluated in unexpected ways by common redirect allow list implementations in Express applications, leading to an Open Redirect via bypass of a properly implemented allow list. The main method i

    • Actualiza a 4.17.1-2ubuntu0.1~esm1
    Publicación Actualización
  3. CVE-2022-24999

    Alta · CVSS 7.5EPSS 15,62%Corrección disponible

    CVE-2022-24999

    qs before 6.10.3, as used in Express before 4.17.3 and other products, allows attackers to cause a Node process hang for an Express application because an __ proto__ key can be used. In many typical Express use cases, an unauthenticated remote attacker can place the attack payload in the query string of the URL that is used to visit the application, such as a[__proto__]=b&a[__proto__]&a[length]=100000000. The fix was backported to qs 6.9.7, 6.8.3, 6.7.3, 6.6.1, 6.5.3, 6.4.1, 6.3.3, and 6.2.4 (and therefore Express 4.17.3, which has "deps: [email protected]" in its release description, is not vulnerable).

    • Actualiza a 4.17.1-2ubuntu0.1~esm2
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →