p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in node-express

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für node-express: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 3

  1. CVE-2024-43796

    Mittel · CVSS 5EPSS 0,49%Korrektur verfügbar

    express vulnerable to XSS via response.redirect()

    Express.js minimalist web framework for node. In express < 4.20.0, passing untrusted user input - even after sanitizing it - to response.redirect() may execute untrusted code. This issue is patched in express 4.20.0.

    • Auf 4.17.1-2ubuntu0.1~esm1 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2024-29041

    Mittel · CVSS 6.1EPSS 0,79%Korrektur verfügbar

    Express.js Open Redirect in malformed URLs

    Express.js minimalist web framework for node. Versions of Express.js prior to 4.19.0 and all pre-release alpha and beta versions of 5.0 are affected by an open redirect vulnerability using malformed URLs. When a user of Express performs a redirect using a user-provided URL Express performs an encode [using `encodeurl`](https://github.com/pillarjs/encodeurl) on the contents before passing it to the `location` header. This can cause malformed URLs to be evaluated in unexpected ways by common redirect allow list implementations in Express applications, leading to an Open Redirect via bypass of a properly implemented allow list. The main method i

    • Auf 4.17.1-2ubuntu0.1~esm1 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2022-24999

    Hoch · CVSS 7.5EPSS 15,62%Korrektur verfügbar

    CVE-2022-24999

    qs before 6.10.3, as used in Express before 4.17.3 and other products, allows attackers to cause a Node process hang for an Express application because an __ proto__ key can be used. In many typical Express use cases, an unauthenticated remote attacker can place the attack payload in the query string of the URL that is used to visit the application, such as a[__proto__]=b&a[__proto__]&a[length]=100000000. The fix was backported to qs 6.9.7, 6.8.3, 6.7.3, 6.6.1, 6.5.3, 6.4.1, 6.3.3, and 6.2.4 (and therefore Express 4.17.3, which has "deps: [email protected]" in its release description, is not vulnerable).

    • Auf 4.17.1-2ubuntu0.1~esm2 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →