p PatchFirst

USN-4367-2

USN-4367-2 · linux regression

Corrección disponible

¿Te afecta?

  • linux Ubuntu 20.04 LTSActualiza a 5.4.0-33.37

Comprueba la versión instalada:

dpkg-query -W -f='${source:Package} ${binary:Package} ${Version}\n' | awk '$1=="linux"'

La comprobación gratuita muestra la puntuación de tu servidor y señala si linux y el resto del software necesitan atención. Sin registro; los nombres de los servidores y las direcciones IP no se envían. Los identificadores CVE, las versiones corregidas y las recomendaciones están en la monitorización de pago.

curl -fsSL https://patchfirst.dev/check.sh | sh
Comprobar tu servidor gratis →

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

USN-4367-1 fixed vulnerabilities in the 5.4 Linux kernel. Unfortunately, that update introduced a regression in overlayfs. This update corrects the problem. We apologize for the inconvenience. Original advisory details: It was discovered that the btrfs implementation in the Linux kernel did not properly detect that a block was marked dirty in some situations. An attacker could use this to specially craft a file system image that, when unmounted, could cause a denial of service (system crash). (CVE-2019-19377) It was discovered that the linux kernel did not properly validate certain mount options to the tmpfs virtual memory file system. A local attacker with the ability to specify mount options could use this to cause a denial of service (system crash). (CVE-2020-11565) It was discovered that the block layer in the Linux kernel contained a race condition leading to a use-after-free vulnerability. A local attacker could possibly use this to cause a denial of service (system crash) or execute arbitrary code. (CVE-2020-12657)

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • linux Ubuntu 20.04 LTS

    Versiones
    • 5.3.0-18.19
    • 5.3.0-24.26
    • 5.4.0-9.12
    • 5.4.0-18.22
    • 5.4.0-21.25
    • 5.4.0-24.28
    Todas las versiones (11)
    • 5.4.0-25.29
    • 5.4.0-26.30
    • 5.4.0-28.32
    • 5.4.0-29.33
    • 5.4.0-31.35
    Intervalos de versiones afectados
    • ECOSYSTEM: < 5.4.0-33.37

    Actualiza a 5.4.0-33.37

Fuentes originales

Comprueba tu servidor →