USN-4367-2
USN-4367-2 · linux regression
Correctif disponible
Êtes-vous concerné ?
- linux Ubuntu 20.04 LTSMettez à jour vers 5.4.0-33.37
Vérifiez la version installée :
dpkg-query -W -f='${source:Package} ${binary:Package} ${Version}\n' | awk '$1=="linux"'La vérification gratuite donne la note de votre serveur et signale si linux et les autres logiciels demandent votre attention. Sans inscription ; les noms des serveurs et les adresses IP ne sont pas envoyés. Les identifiants CVE, les versions corrigées et les recommandations sont réservés à la surveillance payante.
curl -fsSL https://patchfirst.dev/check.sh | shCette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
USN-4367-1 fixed vulnerabilities in the 5.4 Linux kernel. Unfortunately, that update introduced a regression in overlayfs. This update corrects the problem. We apologize for the inconvenience. Original advisory details: It was discovered that the btrfs implementation in the Linux kernel did not properly detect that a block was marked dirty in some situations. An attacker could use this to specially craft a file system image that, when unmounted, could cause a denial of service (system crash). (CVE-2019-19377) It was discovered that the linux kernel did not properly validate certain mount options to the tmpfs virtual memory file system. A local attacker with the ability to specify mount options could use this to cause a denial of service (system crash). (CVE-2020-11565) It was discovered that the block layer in the Linux kernel contained a race condition leading to a use-after-free vulnerability. A local attacker could possibly use this to cause a denial of service (system crash) or execute arbitrary code. (CVE-2020-12657)
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
linux Ubuntu 20.04 LTS
- Versions du logiciel
- 5.3.0-18.19
- 5.3.0-24.26
- 5.4.0-9.12
- 5.4.0-18.22
- 5.4.0-21.25
- 5.4.0-24.28
Toutes les versions (11)
- 5.4.0-25.29
- 5.4.0-26.30
- 5.4.0-28.32
- 5.4.0-29.33
- 5.4.0-31.35
- Plages de versions concernées
- ECOSYSTEM: < 5.4.0-33.37
Mettez à jour vers 5.4.0-33.37