USN-4367-2
USN-4367-2 · linux regression
Korrektur verfügbar
Sind Sie betroffen?
- linux Ubuntu 20.04 LTSAuf 5.4.0-33.37 aktualisieren
Installierte Version prüfen:
dpkg-query -W -f='${source:Package} ${binary:Package} ${Version}\n' | awk '$1=="linux"'Die kostenlose Prüfung zeigt die Bewertung Ihres Servers und markiert, ob linux und die übrige Software Aufmerksamkeit brauchen. Ohne Registrierung; Servernamen und IP-Adressen werden nicht übertragen. CVE-Nummern, korrigierte Versionen und Empfehlungen gibt es in der kostenpflichtigen Überwachung.
curl -fsSL https://patchfirst.dev/check.sh | shDiese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
USN-4367-1 fixed vulnerabilities in the 5.4 Linux kernel. Unfortunately, that update introduced a regression in overlayfs. This update corrects the problem. We apologize for the inconvenience. Original advisory details: It was discovered that the btrfs implementation in the Linux kernel did not properly detect that a block was marked dirty in some situations. An attacker could use this to specially craft a file system image that, when unmounted, could cause a denial of service (system crash). (CVE-2019-19377) It was discovered that the linux kernel did not properly validate certain mount options to the tmpfs virtual memory file system. A local attacker with the ability to specify mount options could use this to cause a denial of service (system crash). (CVE-2020-11565) It was discovered that the block layer in the Linux kernel contained a race condition leading to a use-after-free vulnerability. A local attacker could possibly use this to cause a denial of service (system crash) or execute arbitrary code. (CVE-2020-12657)
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
linux Ubuntu 20.04 LTS
- Softwareversionen
- 5.3.0-18.19
- 5.3.0-24.26
- 5.4.0-9.12
- 5.4.0-18.22
- 5.4.0-21.25
- 5.4.0-24.28
Alle Versionen (11)
- 5.4.0-25.29
- 5.4.0-26.30
- 5.4.0-28.32
- 5.4.0-29.33
- 5.4.0-31.35
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5.4.0-33.37
Auf 5.4.0-33.37 aktualisieren