p PatchFirst

CVE-2018-1000127

CVE-2018-1000127

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

memcached version prior to 1.4.37 contains an Integer Overflow vulnerability in items.c:item_free() that can result in data corruption and deadlocks due to items existing in hash table being reused from free list. This attack appear to be exploitable via network connectivity to the memcached service. This vulnerability appears to have been fixed in 1.4.37 and later.

CVSS 7.5 · Élevée · EPSS 2,3% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system · database

Produits et versions concernés

  • n/a

    Versions du logiciel
    • n/a: Concernée

    Aucun correctif publié

  • memcached Debian:12

    Plages de versions concernées
    • ECOSYSTEM: < 1.5.0-1

    Mettez à jour vers 1.5.0-1

  • memcached Debian:13

    Plages de versions concernées
    • ECOSYSTEM: < 1.5.0-1

    Mettez à jour vers 1.5.0-1

  • memcached Debian:14

    Plages de versions concernées
    • ECOSYSTEM: < 1.5.0-1

    Mettez à jour vers 1.5.0-1

  • memcached Ubuntu:14.04:LTS

    Versions du logiciel
    • 1.4.14-0ubuntu4
    • 1.4.14-0ubuntu8
    • 1.4.14-0ubuntu9
    • 1.4.14-0ubuntu9.1
    • 1.4.14-0ubuntu9.2
    Plages de versions concernées
    • ECOSYSTEM: < 1.4.14-0ubuntu9.3

    Mettez à jour vers 1.4.14-0ubuntu9.3

  • memcached Ubuntu:16.04:LTS

    Versions du logiciel
    • 1.4.24-2ubuntu1
    • 1.4.25-1ubuntu2
    • 1.4.25-2ubuntu1
    • 1.4.25-2ubuntu1.2
    • 1.4.25-2ubuntu1.3
    Plages de versions concernées
    • ECOSYSTEM: < 1.4.25-2ubuntu1.4

    Mettez à jour vers 1.4.25-2ubuntu1.4

Sources originales

Vérifiez votre serveur →