p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de memcached

Vulnérabilité publiée pour memcached au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 6

  1. CVE-2018-1000127

    Élevée · CVSS 7.5EPSS 2,27%Correctif disponible

    CVE-2018-1000127

    memcached version prior to 1.4.37 contains an Integer Overflow vulnerability in items.c:item_free() that can result in data corruption and deadlocks due to items existing in hash table being reused from free list. This attack appear to be exploitable via network connectivity to the memcached service. This vulnerability appears to have been fixed in 1.4.37 and later.

    • Mettez à jour vers 1.4.14-0ubuntu9.3
    Publication Mise à jour
  2. CVE-2018-1000115

    Élevée · CVSS 7.5EPSS 88%Code d’exploitation publicCorrectif disponible

    CVE-2018-1000115

    Memcached version 1.5.5 contains an Insufficient Control of Network Message Volume (Network Amplification, CWE-406) vulnerability in the UDP support of the memcached server that can result in denial of service via network flood (traffic amplification of 1:50,000 has been reported by reliable sources). This attack appear to be exploitable via network connectivity to port 11211 UDP. This vulnerability appears to have been fixed in 1.5.6 due to the disabling of the UDP protocol by default.

    • Mettez à jour vers 1.4.14-0ubuntu9.2
    Publication Mise à jour
  3. CVE-2017-9951

    Élevée · CVSS 7.5EPSS 4,17%Correctif disponible

    CVE-2017-9951

    The try_read_command function in memcached.c in memcached before 1.4.39 allows remote attackers to cause a denial of service (segmentation fault) via a request to add/set a key, which makes a comparison between signed and unsigned int and triggers a heap-based buffer over-read. NOTE: this vulnerability exists because of an incomplete fix for CVE-2016-8705.

    • Mettez à jour vers 1.4.14-0ubuntu9.2
    Publication Mise à jour
  4. CVE-2016-8706

    Élevée · CVSS 8.1EPSS 45,7%Code d’exploitation publicCorrectif disponible

    CVE-2016-8706

    An integer overflow in process_bin_sasl_auth function in Memcached, which is responsible for authentication commands of Memcached binary protocol, can be abused to cause heap overflow and lead to remote code execution.

    • Mettez à jour vers 1.4.14-0ubuntu9.1
    Publication Mise à jour
  5. CVE-2016-8705

    Critique · CVSS 9.8EPSS 19,85%Correctif disponible

    CVE-2016-8705

    Multiple integer overflows in process_bin_update function in Memcached, which is responsible for processing multiple commands of Memcached binary protocol, can be abused to cause heap overflow and lead to remote code execution.

    • Mettez à jour vers 1.4.14-0ubuntu9.1
    Publication Mise à jour
  6. CVE-2016-8704

    Critique · CVSS 9.8EPSS 23,17%Correctif disponible

    CVE-2016-8704

    An integer overflow in the process_bin_append_prepend function in Memcached, which is responsible for processing multiple commands of Memcached binary protocol, can be abused to cause heap overflow and lead to remote code execution.

    • Mettez à jour vers 1.4.14-0ubuntu9.1
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →