p PatchFirst

CVE-2021-21311

CVE-2021-21311 · SSRF in adminer

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Adminer is an open-source database management in a single PHP file. In adminer from version 4.0.0 and before 4.7.9 there is a server-side request forgery vulnerability. Users of Adminer versions bundling all drivers (e.g. `adminer.php`) are affected. This is fixed in version 4.7.9.

CVSS 7.2 · Élevée · EPSS 98,5% · Dans le catalogue KEV · Code d’exploitation public · Correctif disponible

Publication
Mise à jour

Pile logicielle: system · php

Produits et versions concernés

  • adminer

    Versions du logiciel
    • >= 4.0.0, < 4.7.9: Concernée

    Aucun correctif publié

  • adminer Debian:12

    Plages de versions concernées
    • ECOSYSTEM: < 4.7.9-1

    Mettez à jour vers 4.7.9-1

  • adminer Debian:13

    Plages de versions concernées
    • ECOSYSTEM: < 4.7.9-1

    Mettez à jour vers 4.7.9-1

  • adminer Debian:14

    Plages de versions concernées
    • ECOSYSTEM: < 4.7.9-1

    Mettez à jour vers 4.7.9-1

  • vrana/adminer Packagist

    Versions du logiciel
    • v4.2.0
    • v4.2.1
    • v4.2.2
    • v4.2.3
    • v4.2.4
    • v4.2.5
    • v4.3.0
    • v4.3.1
    • v4.4.0
    • v4.5.0
    • v4.6.0
    • v4.6.1
    • v4.6.2
    • v4.6.3
    • v4.7.0
    • v4.7.1
    • v4.7.2
    • v4.7.3
    • v4.7.4
    • v4.7.5
    • v4.7.6
    • v4.7.7
    • v4.7.8
    Plages de versions concernées
    • ECOSYSTEM: < 4.7.9

    Mettez à jour vers 4.7.9

  • adminer Ubuntu:Pro:16.04:LTS

    Versions du logiciel
    • 4.2.1-1
    • 4.2.1-1ubuntu1
    Plages de versions concernées
    • ECOSYSTEM: < 4.2.1-1ubuntu1+esm1

    Mettez à jour vers 4.2.1-1ubuntu1+esm1

  • adminer Ubuntu:Pro:18.04:LTS

    Versions du logiciel
    • 4.3.1-2
    • 4.5.0-1
    • 4.6.1-1
    • 4.6.2-1
    Plages de versions concernées
    • ECOSYSTEM: < 4.6.2-1ubuntu0.1~esm1

    Mettez à jour vers 4.6.2-1ubuntu0.1~esm1

  • adminer Ubuntu:Pro:20.04:LTS

    Versions du logiciel
    • 4.7.2-1
    • 4.7.4-1
    • 4.7.5-1
    • 4.7.6-1
    Plages de versions concernées
    • ECOSYSTEM: < 4.7.6-1ubuntu0.1~esm1

    Mettez à jour vers 4.7.6-1ubuntu0.1~esm1

Sources originales

Vérifiez votre serveur →