p PatchFirst

CVE-2021-21311

CVE-2021-21311 · SSRF in adminer

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Adminer is an open-source database management in a single PHP file. In adminer from version 4.0.0 and before 4.7.9 there is a server-side request forgery vulnerability. Users of Adminer versions bundling all drivers (e.g. `adminer.php`) are affected. This is fixed in version 4.7.9.

CVSS 7.2 · Hoch · EPSS 98,5% · Im KEV-Katalog · Öffentlicher Exploit · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · php

Betroffene Produkte und Versionen

  • adminer

    Softwareversionen
    • >= 4.0.0, < 4.7.9: Betroffen

    Keine Korrektur veröffentlicht

  • adminer Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 4.7.9-1

    Auf 4.7.9-1 aktualisieren

  • adminer Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 4.7.9-1

    Auf 4.7.9-1 aktualisieren

  • adminer Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 4.7.9-1

    Auf 4.7.9-1 aktualisieren

  • vrana/adminer Packagist

    Softwareversionen
    • v4.2.0
    • v4.2.1
    • v4.2.2
    • v4.2.3
    • v4.2.4
    • v4.2.5
    • v4.3.0
    • v4.3.1
    • v4.4.0
    • v4.5.0
    • v4.6.0
    • v4.6.1
    • v4.6.2
    • v4.6.3
    • v4.7.0
    • v4.7.1
    • v4.7.2
    • v4.7.3
    • v4.7.4
    • v4.7.5
    • v4.7.6
    • v4.7.7
    • v4.7.8
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 4.7.9

    Auf 4.7.9 aktualisieren

  • adminer Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 4.2.1-1
    • 4.2.1-1ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 4.2.1-1ubuntu1+esm1

    Auf 4.2.1-1ubuntu1+esm1 aktualisieren

  • adminer Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 4.3.1-2
    • 4.5.0-1
    • 4.6.1-1
    • 4.6.2-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 4.6.2-1ubuntu0.1~esm1

    Auf 4.6.2-1ubuntu0.1~esm1 aktualisieren

  • adminer Ubuntu:Pro:20.04:LTS

    Softwareversionen
    • 4.7.2-1
    • 4.7.4-1
    • 4.7.5-1
    • 4.7.6-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 4.7.6-1ubuntu0.1~esm1

    Auf 4.7.6-1ubuntu0.1~esm1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →