p PatchFirst

CVE-2021-21311

CVE-2021-21311 · SSRF in adminer

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Adminer is an open-source database management in a single PHP file. In adminer from version 4.0.0 and before 4.7.9 there is a server-side request forgery vulnerability. Users of Adminer versions bundling all drivers (e.g. `adminer.php`) are affected. This is fixed in version 4.7.9.

CVSS 7.2 · High · EPSS 98.5% · In KEV · Public exploit · Fix available

Published
Updated

Stack: system · php

Affected products and versions

  • adminer

    Versions
    • >= 4.0.0, < 4.7.9: Affected

    No fix published

  • adminer Debian:12

    Affected ranges
    • ECOSYSTEM: < 4.7.9-1

    Update to 4.7.9-1

  • adminer Debian:13

    Affected ranges
    • ECOSYSTEM: < 4.7.9-1

    Update to 4.7.9-1

  • adminer Debian:14

    Affected ranges
    • ECOSYSTEM: < 4.7.9-1

    Update to 4.7.9-1

  • vrana/adminer Packagist

    Versions
    • v4.2.0
    • v4.2.1
    • v4.2.2
    • v4.2.3
    • v4.2.4
    • v4.2.5
    • v4.3.0
    • v4.3.1
    • v4.4.0
    • v4.5.0
    • v4.6.0
    • v4.6.1
    • v4.6.2
    • v4.6.3
    • v4.7.0
    • v4.7.1
    • v4.7.2
    • v4.7.3
    • v4.7.4
    • v4.7.5
    • v4.7.6
    • v4.7.7
    • v4.7.8
    Affected ranges
    • ECOSYSTEM: < 4.7.9

    Update to 4.7.9

  • adminer Ubuntu:Pro:16.04:LTS

    Versions
    • 4.2.1-1
    • 4.2.1-1ubuntu1
    Affected ranges
    • ECOSYSTEM: < 4.2.1-1ubuntu1+esm1

    Update to 4.2.1-1ubuntu1+esm1

  • adminer Ubuntu:Pro:18.04:LTS

    Versions
    • 4.3.1-2
    • 4.5.0-1
    • 4.6.1-1
    • 4.6.2-1
    Affected ranges
    • ECOSYSTEM: < 4.6.2-1ubuntu0.1~esm1

    Update to 4.6.2-1ubuntu0.1~esm1

  • adminer Ubuntu:Pro:20.04:LTS

    Versions
    • 4.7.2-1
    • 4.7.4-1
    • 4.7.5-1
    • 4.7.6-1
    Affected ranges
    • ECOSYSTEM: < 4.7.6-1ubuntu0.1~esm1

    Update to 4.7.6-1ubuntu0.1~esm1

Original sources

Check your server →