CVE-2021-3481
CVE-2021-3481
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
A flaw was found in Qt. An out-of-bounds read vulnerability was found in QRadialFetchSimd in qt/qtbase/src/gui/painting/qdrawhelper_p.h in Qt/Qtbase. While rendering and displaying a crafted Scalable Vector Graphics (SVG) file this flaw may lead to an unauthorized memory access. The highest threat from this vulnerability is to data confidentiality and the application availability.
CVSS 7.1 · Élevée · EPSS 0,5% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
qt
- Versions du logiciel
- Fixed in qt 5.12.11, qt 5.15.4, qt 6.0.3, qt 6.1.0RC.: Concernée
Aucun correctif publié
qtsvg-opensource-src Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 5.15.2-3
Mettez à jour vers 5.15.2-3
qtsvg-opensource-src Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 5.15.2-3
Mettez à jour vers 5.15.2-3
qtsvg-opensource-src Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 5.15.2-3
Mettez à jour vers 5.15.2-3
qt4-x11 Ubuntu:14.04:LTS
- Versions du logiciel
- 4:4.8.4+dfsg-0ubuntu18
- 4:4.8.4+dfsg-0ubuntu19
- 4:4.8.4+dfsg-0ubuntu20
- 4:4.8.4+dfsg-0ubuntu21
- 4:4.8.4+dfsg-0ubuntu22
- 4:4.8.5+git192-g085f851+dfsg-2ubuntu3
- 4:4.8.5+git192-g085f851+dfsg-2ubuntu4
- 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
qt4-x11 Ubuntu:16.04:LTS
- Versions du logiciel
- 4:4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu8
- 4:4.8.7+dfsg-5ubuntu1
- 4:4.8.7+dfsg-5ubuntu2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
qtsvg-opensource-src Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 5.4.2-2build1
- 5.5.1-2build1
- Plages de versions concernées
- ECOSYSTEM: < 5.5.1-2ubuntu0.1~esm1
Mettez à jour vers 5.5.1-2ubuntu0.1~esm1
qtsvg-opensource-src Ubuntu:18.04:LTS
- Versions du logiciel
- 5.9.1-2
- 5.9.2-2
- 5.9.2-3
- 5.9.3-0ubuntu1
- 5.9.4-0ubuntu1
- 5.9.5-0ubuntu1
- Plages de versions concernées
- ECOSYSTEM: < 5.9.5-0ubuntu1.1
Mettez à jour vers 5.9.5-0ubuntu1.1
qt4-x11 Ubuntu:18.04:LTS
- Versions du logiciel
- 4:4.8.7+dfsg-7ubuntu1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
qtsvg-opensource-src Ubuntu:Pro:20.04:LTS
- Versions du logiciel
- 5.12.4-1
- 5.12.5-2
- 5.12.5-2build1
- 5.12.8-0ubuntu1
- Plages de versions concernées
- ECOSYSTEM: < 5.12.8-0ubuntu1+esm1
Mettez à jour vers 5.12.8-0ubuntu1+esm1
Sources originales
- https://bugreports.qt.io/browse/QTBUG-91507
- https://codereview.qt-project.org/c/qt/qtsvg/+/337646
- https://bugzilla.redhat.com/show_bug.cgi?id=1931444
- https://access.redhat.com/security/cve/CVE-2021-3481
- https://lists.debian.org/debian-lts-announce/2023/08/msg00028.html
- https://nvd.nist.gov/vuln/detail/CVE-2021-3481