p PatchFirst

CVE-2021-3481

CVE-2021-3481

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

A flaw was found in Qt. An out-of-bounds read vulnerability was found in QRadialFetchSimd in qt/qtbase/src/gui/painting/qdrawhelper_p.h in Qt/Qtbase. While rendering and displaying a crafted Scalable Vector Graphics (SVG) file this flaw may lead to an unauthorized memory access. The highest threat from this vulnerability is to data confidentiality and the application availability.

CVSS 7.1 · Hoch · EPSS 0,5% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • qt

    Softwareversionen
    • Fixed in qt 5.12.11, qt 5.15.4, qt 6.0.3, qt 6.1.0RC.: Betroffen

    Keine Korrektur veröffentlicht

  • qtsvg-opensource-src Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.15.2-3

    Auf 5.15.2-3 aktualisieren

  • qtsvg-opensource-src Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.15.2-3

    Auf 5.15.2-3 aktualisieren

  • qtsvg-opensource-src Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.15.2-3

    Auf 5.15.2-3 aktualisieren

  • qt4-x11 Ubuntu:14.04:LTS

    Softwareversionen
    • 4:4.8.4+dfsg-0ubuntu18
    • 4:4.8.4+dfsg-0ubuntu19
    • 4:4.8.4+dfsg-0ubuntu20
    • 4:4.8.4+dfsg-0ubuntu21
    • 4:4.8.4+dfsg-0ubuntu22
    • 4:4.8.5+git192-g085f851+dfsg-2ubuntu3
    • 4:4.8.5+git192-g085f851+dfsg-2ubuntu4
    • 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • qt4-x11 Ubuntu:16.04:LTS

    Softwareversionen
    • 4:4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu8
    • 4:4.8.7+dfsg-5ubuntu1
    • 4:4.8.7+dfsg-5ubuntu2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • qtsvg-opensource-src Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 5.4.2-2build1
    • 5.5.1-2build1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.5.1-2ubuntu0.1~esm1

    Auf 5.5.1-2ubuntu0.1~esm1 aktualisieren

  • qtsvg-opensource-src Ubuntu:18.04:LTS

    Softwareversionen
    • 5.9.1-2
    • 5.9.2-2
    • 5.9.2-3
    • 5.9.3-0ubuntu1
    • 5.9.4-0ubuntu1
    • 5.9.5-0ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.9.5-0ubuntu1.1

    Auf 5.9.5-0ubuntu1.1 aktualisieren

  • qt4-x11 Ubuntu:18.04:LTS

    Softwareversionen
    • 4:4.8.7+dfsg-7ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • qtsvg-opensource-src Ubuntu:Pro:20.04:LTS

    Softwareversionen
    • 5.12.4-1
    • 5.12.5-2
    • 5.12.5-2build1
    • 5.12.8-0ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.12.8-0ubuntu1+esm1

    Auf 5.12.8-0ubuntu1+esm1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →