CVE-2022-41905
CVE-2022-41905 · wsgidav is vulnerable to Cross-Site Scripting (XSS) when directory browsing is enabled
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
WsgiDAV is a generic and extendable WebDAV server based on WSGI. Implementations using this library with directory browsing enabled may be susceptible to Cross Site Scripting (XSS) attacks. This issue has been patched, users can upgrade to version 4.1.0. As a workaround, set `dir_browser.enable = False` in the configuration.
CVSS 8.2 · Élevée · EPSS 0,4% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: python
Produits et versions concernés
wsgidav
- Versions du logiciel
- >= 3.0.0a1, < 4.1.0: Concernée
Aucun correctif publié
wsgidav PyPI
- Versions du logiciel
- 3.0.0
- 3.0.0a1
- 3.0.0a2
- 3.0.0a3
- 3.0.0a4
- 3.0.0a5
- 3.0.0a6
- 3.0.0a7
- 3.0.1
- 3.0.2
- 3.0.3
- 3.0.5a2
- 3.0.5a3
- 3.1.0
- 3.1.1
- 4.0.0
- 4.0.0a2
- 4.0.1
- 4.0.2
- Plages de versions concernées
- ECOSYSTEM: ≥ 3.0.0a1, < 4.1.0
Mettez à jour vers 4.1.0
wsgidav PyPI
- Versions du logiciel
- 3.0.0
- 3.0.1
- 3.0.2
- 3.0.3
- 3.0.5a2
- 3.0.5a3
- 3.1.0
- 3.1.1
- 4.0.0
- 4.0.0a2
- 4.0.1
- 4.0.2
- Plages de versions concernées
- GIT: < e9606ab0f42f4c1a6611bc3c52de299b0aba7726
- ECOSYSTEM: ≥ 3.0.0, < 4.1.0
Mettez à jour vers 4.1.0