CVE-2022-41905
CVE-2022-41905 · wsgidav is vulnerable to Cross-Site Scripting (XSS) when directory browsing is enabled
This page contains facts from public vulnerability sources. Check the original advisory before updating.
WsgiDAV is a generic and extendable WebDAV server based on WSGI. Implementations using this library with directory browsing enabled may be susceptible to Cross Site Scripting (XSS) attacks. This issue has been patched, users can upgrade to version 4.1.0. As a workaround, set `dir_browser.enable = False` in the configuration.
CVSS 8.2 · High · EPSS 0.4% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
wsgidav
- Versions
- >= 3.0.0a1, < 4.1.0: Affected
No fix published
wsgidav PyPI
- Versions
- 3.0.0
- 3.0.0a1
- 3.0.0a2
- 3.0.0a3
- 3.0.0a4
- 3.0.0a5
- 3.0.0a6
- 3.0.0a7
- 3.0.1
- 3.0.2
- 3.0.3
- 3.0.5a2
- 3.0.5a3
- 3.1.0
- 3.1.1
- 4.0.0
- 4.0.0a2
- 4.0.1
- 4.0.2
- Affected ranges
- ECOSYSTEM: ≥ 3.0.0a1, < 4.1.0
Update to 4.1.0
wsgidav PyPI
- Versions
- 3.0.0
- 3.0.1
- 3.0.2
- 3.0.3
- 3.0.5a2
- 3.0.5a3
- 3.1.0
- 3.1.1
- 4.0.0
- 4.0.0a2
- 4.0.1
- 4.0.2
- Affected ranges
- GIT: < e9606ab0f42f4c1a6611bc3c52de299b0aba7726
- ECOSYSTEM: ≥ 3.0.0, < 4.1.0
Update to 4.1.0