p PatchFirst

CVE-2022-42920

CVE-2022-42920 · Apache Commons BCEL prior to 6.6.0 allows producing arbitrary bytecode via out-of-bounds writing

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Apache Commons BCEL has a number of APIs that would normally only allow changing specific class characteristics. However, due to an out-of-bounds writing issue, these APIs can be used to produce arbitrary bytecode. This could be abused in applications that pass attacker-controllable data to those APIs, giving the attacker more control over the resulting bytecode than otherwise expected. Update to Apache Commons BCEL 6.6.0.

CVSS 9.8 · Critique · EPSS 2,8% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system

Produits et versions concernés

  • apache commons bcel

    Versions du logiciel
    • ≥ Apache Commons BCEL, < 6.6.0: Concernée (custom)

    Mettez à jour vers 6.6.0

  • bcel Debian:12

    Plages de versions concernées
    • ECOSYSTEM: < 6.5.0-2

    Mettez à jour vers 6.5.0-2

  • bcel Debian:13

    Plages de versions concernées
    • ECOSYSTEM: < 6.5.0-2

    Mettez à jour vers 6.5.0-2

  • bcel Debian:14

    Plages de versions concernées
    • ECOSYSTEM: < 6.5.0-2

    Mettez à jour vers 6.5.0-2

  • bcel Ubuntu:Pro:16.04:LTS

    Versions du logiciel
    • 6.0~rc3-1ubuntu1
    • 6.0~rc3-2ubuntu1
    Plages de versions concernées
    • ECOSYSTEM: < 6.0~rc3-2ubuntu1+esm1

    Mettez à jour vers 6.0~rc3-2ubuntu1+esm1

  • bcel Ubuntu:Pro:18.04:LTS

    Versions du logiciel
    • 6.0-1
    • 6.1-1
    • 6.2-1
    Plages de versions concernées
    • ECOSYSTEM: < 6.2-1ubuntu0.1~esm1

    Mettez à jour vers 6.2-1ubuntu0.1~esm1

  • bcel Ubuntu:Pro:20.04:LTS

    Versions du logiciel
    • 6.3-1
    • 6.4.1-1
    Plages de versions concernées
    • ECOSYSTEM: < 6.4.1-1ubuntu0.1~esm1

    Mettez à jour vers 6.4.1-1ubuntu0.1~esm1

  • bcel Ubuntu:22.04:LTS

    Versions du logiciel
    • 6.5.0-1
    Plages de versions concernées
    • ECOSYSTEM: < 6.5.0-1ubuntu0.1

    Mettez à jour vers 6.5.0-1ubuntu0.1

Sources originales

Vérifiez votre serveur →