p PatchFirst

CVE-2022-42920

CVE-2022-42920 · Apache Commons BCEL prior to 6.6.0 allows producing arbitrary bytecode via out-of-bounds writing

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Apache Commons BCEL has a number of APIs that would normally only allow changing specific class characteristics. However, due to an out-of-bounds writing issue, these APIs can be used to produce arbitrary bytecode. This could be abused in applications that pass attacker-controllable data to those APIs, giving the attacker more control over the resulting bytecode than otherwise expected. Update to Apache Commons BCEL 6.6.0.

CVSS 9.8 · Critical · EPSS 2.8% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • apache commons bcel

    Versions
    • ≥ Apache Commons BCEL, < 6.6.0: Affected (custom)

    Update to 6.6.0

  • bcel Debian:12

    Affected ranges
    • ECOSYSTEM: < 6.5.0-2

    Update to 6.5.0-2

  • bcel Debian:13

    Affected ranges
    • ECOSYSTEM: < 6.5.0-2

    Update to 6.5.0-2

  • bcel Debian:14

    Affected ranges
    • ECOSYSTEM: < 6.5.0-2

    Update to 6.5.0-2

  • bcel Ubuntu:Pro:16.04:LTS

    Versions
    • 6.0~rc3-1ubuntu1
    • 6.0~rc3-2ubuntu1
    Affected ranges
    • ECOSYSTEM: < 6.0~rc3-2ubuntu1+esm1

    Update to 6.0~rc3-2ubuntu1+esm1

  • bcel Ubuntu:Pro:18.04:LTS

    Versions
    • 6.0-1
    • 6.1-1
    • 6.2-1
    Affected ranges
    • ECOSYSTEM: < 6.2-1ubuntu0.1~esm1

    Update to 6.2-1ubuntu0.1~esm1

  • bcel Ubuntu:Pro:20.04:LTS

    Versions
    • 6.3-1
    • 6.4.1-1
    Affected ranges
    • ECOSYSTEM: < 6.4.1-1ubuntu0.1~esm1

    Update to 6.4.1-1ubuntu0.1~esm1

  • bcel Ubuntu:22.04:LTS

    Versions
    • 6.5.0-1
    Affected ranges
    • ECOSYSTEM: < 6.5.0-1ubuntu0.1

    Update to 6.5.0-1ubuntu0.1

Original sources

Check your server →