CVE-2022-42920
CVE-2022-42920 · Apache Commons BCEL prior to 6.6.0 allows producing arbitrary bytecode via out-of-bounds writing
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Apache Commons BCEL has a number of APIs that would normally only allow changing specific class characteristics. However, due to an out-of-bounds writing issue, these APIs can be used to produce arbitrary bytecode. This could be abused in applications that pass attacker-controllable data to those APIs, giving the attacker more control over the resulting bytecode than otherwise expected. Update to Apache Commons BCEL 6.6.0.
CVSS 9.8 · Kritisch · EPSS 2,8% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
apache commons bcel
- Softwareversionen
- ≥ Apache Commons BCEL, < 6.6.0: Betroffen (custom)
Auf 6.6.0 aktualisieren
bcel Debian:12
- Betroffene Versionsbereiche
- ECOSYSTEM: < 6.5.0-2
Auf 6.5.0-2 aktualisieren
bcel Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 6.5.0-2
Auf 6.5.0-2 aktualisieren
bcel Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 6.5.0-2
Auf 6.5.0-2 aktualisieren
bcel Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 6.0~rc3-1ubuntu1
- 6.0~rc3-2ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 6.0~rc3-2ubuntu1+esm1
Auf 6.0~rc3-2ubuntu1+esm1 aktualisieren
bcel Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 6.0-1
- 6.1-1
- 6.2-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 6.2-1ubuntu0.1~esm1
Auf 6.2-1ubuntu0.1~esm1 aktualisieren
bcel Ubuntu:Pro:20.04:LTS
- Softwareversionen
- 6.3-1
- 6.4.1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 6.4.1-1ubuntu0.1~esm1
Auf 6.4.1-1ubuntu0.1~esm1 aktualisieren
bcel Ubuntu:22.04:LTS
- Softwareversionen
- 6.5.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 6.5.0-1ubuntu0.1
Auf 6.5.0-1ubuntu0.1 aktualisieren
Originalquellen
- https://lists.apache.org/thread/lfxk7q8qmnh5bt9jm6nmjlv5hsxjhrz4
- http://www.openwall.com/lists/oss-security/2022/11/07/2
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/LX3HEB4TV2BVCGDTK5BCLSYOZNQTOBN4/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/QMVX6COVXZVS5GPWDODIRW6Z2GE7RPAQ/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/QAMRHAKGIKZNHRBB4VLYTOIOIMMXCUCD/
- https://security.gentoo.org/glsa/202401-25
- https://nvd.nist.gov/vuln/detail/CVE-2022-42920