p PatchFirst

CVE-2023-27597

CVE-2023-27597 · OpenSIPS has vulnerability in the parse_uri() function

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.8 and 3.2.5, when a specially crafted SIP message is processed by the function `rewrite_ruri`, a crash occurs due to a segmentation fault. This issue causes the server to crash. It affects configurations containing functions that make use of the affected code, such as the function `setport`. This issue has been fixed in version 3.1.8 and 3.2.5.

CVSS 7.5 · Élevée · EPSS 0,7%

Publication
Mise à jour

Pile logicielle: system

Produits et versions concernés

  • opensips

    Versions du logiciel
    • < 3.1.8: Concernée
    • >= 3.2.0, < 3.2.5: Concernée

    Aucun correctif publié

  • opensips Ubuntu:18.04:LTS

    Versions du logiciel
    • 2.2.2-3build2
    • 2.2.2-3build3
    • 2.2.2-3build4
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

Sources originales

Vérifiez votre serveur →