p PatchFirst

CVE-2023-27597

CVE-2023-27597 · OpenSIPS has vulnerability in the parse_uri() function

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.8 and 3.2.5, when a specially crafted SIP message is processed by the function `rewrite_ruri`, a crash occurs due to a segmentation fault. This issue causes the server to crash. It affects configurations containing functions that make use of the affected code, such as the function `setport`. This issue has been fixed in version 3.1.8 and 3.2.5.

CVSS 7.5 · High · EPSS 0.7%

Published
Updated

Stack: system

Affected products and versions

  • opensips

    Versions
    • < 3.1.8: Affected
    • >= 3.2.0, < 3.2.5: Affected

    No fix published

  • opensips Ubuntu:18.04:LTS

    Versions
    • 2.2.2-3build2
    • 2.2.2-3build3
    • 2.2.2-3build4
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →