p PatchFirst

CVE-2023-27597

CVE-2023-27597 · OpenSIPS has vulnerability in the parse_uri() function

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.8 and 3.2.5, when a specially crafted SIP message is processed by the function `rewrite_ruri`, a crash occurs due to a segmentation fault. This issue causes the server to crash. It affects configurations containing functions that make use of the affected code, such as the function `setport`. This issue has been fixed in version 3.1.8 and 3.2.5.

CVSS 7.5 · Hoch · EPSS 0,7%

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • opensips

    Softwareversionen
    • < 3.1.8: Betroffen
    • >= 3.2.0, < 3.2.5: Betroffen

    Keine Korrektur veröffentlicht

  • opensips Ubuntu:18.04:LTS

    Softwareversionen
    • 2.2.2-3build2
    • 2.2.2-3build3
    • 2.2.2-3build4
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →