p PatchFirst

CVE-2024-12029

CVE-2024-12029 · Remote Code Execution via Model Deserialization in invoke-ai/invokeai

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

A remote code execution vulnerability exists in invoke-ai/invokeai versions 5.3.1 through 5.4.2 via the /api/v2/models/install API. The vulnerability arises from unsafe deserialization of model files using torch.load without proper validation. Attackers can exploit this by embedding malicious code in model files, which is executed upon loading. This issue is fixed in version 5.4.3.

CVSS 9.8 · Critique · EPSS 6,0% · Code d’exploitation public · Correctif disponible

Publication
Mise à jour

Pile logicielle: python

Produits et versions concernés

  • invoke-ai/invokeai

    Versions du logiciel
    • ≥ unspecified, < 5.4.3: Concernée (custom)

    Mettez à jour vers 5.4.3

  • invokeai PyPI

    Versions du logiciel
    • 5.3.1
    • 5.4.0
    • 5.4.1
    • 5.4.1rc1
    • 5.4.1rc2
    • 5.4.2
    • 5.4.2rc1
    • 5.4.3rc1
    Plages de versions concernées
    • ECOSYSTEM: ≥ 5.3.1, < 5.4.3rc2

    Mettez à jour vers 5.4.3rc2

  • invokeai PyPI

    Versions du logiciel
    • 5.3.1
    • 5.4.0
    • 5.4.1
    • 5.4.1rc1
    • 5.4.1rc2
    • 5.4.2
    • 5.4.2rc1
    Plages de versions concernées
    • GIT: < 756008dc5899081c5aa51e5bd8f24c1b3975a59e
    • ECOSYSTEM: ≥ 5.3.1, < 5.4.3rc1

    Mettez à jour vers 5.4.3rc1

Sources originales

Vérifiez votre serveur →