p PatchFirst

CVE-2024-12029

CVE-2024-12029 · Remote Code Execution via Model Deserialization in invoke-ai/invokeai

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

A remote code execution vulnerability exists in invoke-ai/invokeai versions 5.3.1 through 5.4.2 via the /api/v2/models/install API. The vulnerability arises from unsafe deserialization of model files using torch.load without proper validation. Attackers can exploit this by embedding malicious code in model files, which is executed upon loading. This issue is fixed in version 5.4.3.

CVSS 9.8 · Kritisch · EPSS 6,0% · Öffentlicher Exploit · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: python

Betroffene Produkte und Versionen

  • invoke-ai/invokeai

    Softwareversionen
    • ≥ unspecified, < 5.4.3: Betroffen (custom)

    Auf 5.4.3 aktualisieren

  • invokeai PyPI

    Softwareversionen
    • 5.3.1
    • 5.4.0
    • 5.4.1
    • 5.4.1rc1
    • 5.4.1rc2
    • 5.4.2
    • 5.4.2rc1
    • 5.4.3rc1
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 5.3.1, < 5.4.3rc2

    Auf 5.4.3rc2 aktualisieren

  • invokeai PyPI

    Softwareversionen
    • 5.3.1
    • 5.4.0
    • 5.4.1
    • 5.4.1rc1
    • 5.4.1rc2
    • 5.4.2
    • 5.4.2rc1
    Betroffene Versionsbereiche
    • GIT: < 756008dc5899081c5aa51e5bd8f24c1b3975a59e
    • ECOSYSTEM: ≥ 5.3.1, < 5.4.3rc1

    Auf 5.4.3rc1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →