CVE-2024-12029
CVE-2024-12029 · Remote Code Execution via Model Deserialization in invoke-ai/invokeai
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A remote code execution vulnerability exists in invoke-ai/invokeai versions 5.3.1 through 5.4.2 via the /api/v2/models/install API. The vulnerability arises from unsafe deserialization of model files using torch.load without proper validation. Attackers can exploit this by embedding malicious code in model files, which is executed upon loading. This issue is fixed in version 5.4.3.
CVSS 9.8 · Critical · EPSS 6.0% · Public exploit · Fix available
- Published
- Updated
Stack: python
Affected products and versions
invoke-ai/invokeai
- Versions
- ≥ unspecified, < 5.4.3: Affected (custom)
Update to 5.4.3
invokeai PyPI
- Versions
- 5.3.1
- 5.4.0
- 5.4.1
- 5.4.1rc1
- 5.4.1rc2
- 5.4.2
- 5.4.2rc1
- 5.4.3rc1
- Affected ranges
- ECOSYSTEM: ≥ 5.3.1, < 5.4.3rc2
Update to 5.4.3rc2
invokeai PyPI
- Versions
- 5.3.1
- 5.4.0
- 5.4.1
- 5.4.1rc1
- 5.4.1rc2
- 5.4.2
- 5.4.2rc1
- Affected ranges
- GIT: < 756008dc5899081c5aa51e5bd8f24c1b3975a59e
- ECOSYSTEM: ≥ 5.3.1, < 5.4.3rc1
Update to 5.4.3rc1