p PatchFirst

CVE-2024-41677

CVE-2024-41677 · Cross-site Scripting (XSS) vulnerability due to improper HTML escaping in qwik

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Qwik is a performance focused javascript framework. A potential mutation XSS vulnerability exists in Qwik for versions up to but not including 1.6.0. Qwik improperly escapes HTML on server-side rendering. It converts strings according to the rules found in the `render-ssr.ts` file. It sometimes causes the situation that the final DOM tree rendered on browsers is different from what Qwik expects on server-side rendering. This may be leveraged to perform XSS attacks, and a type of the XSS is known as mXSS (mutation XSS). This has been resolved in qwik version 1.6.0 and @builder.io/qwik version 1.7.3. All users are advised to upgrade. There are no known workarounds for this vulnerability.

CVSS 6.3 · Moyenne · EPSS 0,5% · Correctif disponible

Publication
Mise à jour

Pile logicielle: node

Produits et versions concernés

  • qwik

    Versions du logiciel
    • @builder.io/qwik: < 1.7.3: Concernée
    • qwik: < 1.6.0: Concernée

    Aucun correctif publié

  • @builder.io/qwik npm

    Plages de versions concernées
    • SEMVER: < 1.7.3

    Mettez à jour vers 1.7.3

Sources originales

Vérifiez votre serveur →