p PatchFirst

CVE-2024-41677

CVE-2024-41677 · Cross-site Scripting (XSS) vulnerability due to improper HTML escaping in qwik

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Qwik is a performance focused javascript framework. A potential mutation XSS vulnerability exists in Qwik for versions up to but not including 1.6.0. Qwik improperly escapes HTML on server-side rendering. It converts strings according to the rules found in the `render-ssr.ts` file. It sometimes causes the situation that the final DOM tree rendered on browsers is different from what Qwik expects on server-side rendering. This may be leveraged to perform XSS attacks, and a type of the XSS is known as mXSS (mutation XSS). This has been resolved in qwik version 1.6.0 and @builder.io/qwik version 1.7.3. All users are advised to upgrade. There are no known workarounds for this vulnerability.

CVSS 6.3 · Medium · EPSS 0.5% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • qwik

    Versions
    • @builder.io/qwik: < 1.7.3: Affected
    • qwik: < 1.6.0: Affected

    No fix published

  • @builder.io/qwik npm

    Affected ranges
    • SEMVER: < 1.7.3

    Update to 1.7.3

Original sources

Check your server →