p PatchFirst

CVE-2024-41677

CVE-2024-41677 · Cross-site Scripting (XSS) vulnerability due to improper HTML escaping in qwik

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Qwik is a performance focused javascript framework. A potential mutation XSS vulnerability exists in Qwik for versions up to but not including 1.6.0. Qwik improperly escapes HTML on server-side rendering. It converts strings according to the rules found in the `render-ssr.ts` file. It sometimes causes the situation that the final DOM tree rendered on browsers is different from what Qwik expects on server-side rendering. This may be leveraged to perform XSS attacks, and a type of the XSS is known as mXSS (mutation XSS). This has been resolved in qwik version 1.6.0 and @builder.io/qwik version 1.7.3. All users are advised to upgrade. There are no known workarounds for this vulnerability.

CVSS 6.3 · Mittel · EPSS 0,5% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • qwik

    Softwareversionen
    • @builder.io/qwik: < 1.7.3: Betroffen
    • qwik: < 1.6.0: Betroffen

    Keine Korrektur veröffentlicht

  • @builder.io/qwik npm

    Betroffene Versionsbereiche
    • SEMVER: < 1.7.3

    Auf 1.7.3 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →